Zugriffsverletzung beim Lesen

Moderator: DL7UCX

Benutzeravatar
DL7UCX
Beiträge: 5360
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: Zugriffsverletzung beim Lesen

Beitrag von DL7UCX » Donnerstag 11. April 2013, 13:54

Hallo,

bei mir ist dieser Fehler noch nie aufgetreten, wobei seit einigen Jahren fast nur noch Windows7 64bit läuft.
Ich könnte das nur einkreisen, wenn UcxLog unter meiner Entwicklungsumgebung (mit Debugger) läuft und dann der Fehler auftritt.

Die Frage wäre noch, ob es in allen Fehlerfällen etwas gemeinsames in der Konfiguration gibt (Ports, Treiber, Internet, RTTY).
Wenn es auch ohne Bedienereingaben auftritt, müßte es von außen getriggert werden (DX-Cluster, Ports, Soundkarte/MMTTY).

73 Ben

Benutzeravatar
DL6ER
Beiträge: 1065
Registriert: Montag 7. März 2011, 21:42
Kontaktdaten:

Re: Zugriffsverletzung beim Lesen

Beitrag von DL6ER » Donnerstag 11. April 2013, 15:14

Hallo Ben,

kurzer Nachtrag: Bei mir ist es immer (wobei das wirklich selten war) während des Starts aufgetreten (direkt am Anfang, als sich die Fenster noch aufgebaut haben), hat aber auch keine Beeinträchtigung für den Betrieb ergeben.

73 Dominik

Benutzeravatar
DL7UCX
Beiträge: 5360
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: Zugriffsverletzung beim Lesen

Beitrag von DL7UCX » Donnerstag 11. April 2013, 15:21

Hallo Dominik,

damit ist es aber anscheinend etwas anderes als bei Gerd.
Wie lange ist der letzte Error denn her?

73 Ben

Benutzeravatar
DL6ER
Beiträge: 1065
Registriert: Montag 7. März 2011, 21:42
Kontaktdaten:

Re: Zugriffsverletzung beim Lesen

Beitrag von DL6ER » Donnerstag 11. April 2013, 17:16

Hallo Ben,

das ist wirklich schwer abzuschätzen...auf jeden Fall schon länger...würde auf Januar diesen Jahres tippen, meine Funkaktivität hat aber auch (wegen Schreiben der Abschlussarbeit) drastisch (!) abgenommen.

73 Dominik

DJ4KW
Beiträge: 81
Registriert: Montag 15. Januar 2007, 15:16
Wohnort: 21337 Lüneburg
Kontaktdaten:

"Zugriffsverletzung beim Lesen" WORK-Fenster NAME-Feld

Beitrag von DJ4KW » Mittwoch 17. April 2013, 09:53

Hallo Ben, hallo Dominik,

Betriebssystem hier ist Windows XP Professional, auf Mac Book unter Parallels Desktop und Mac OS 10.6.8. Der Fehler ist nicht reproduzierbar und tritt einfach viel zu selten auf. Heute Nacht hatte ich die Situation, dass ich die Zugriffsverletzung zum ersten Mal mehrmals wiederholt provozieren konnte. Ich war im WORK-Fenster, Frequenz und Betriebsart waren schon automatisch übernommen nachdem ich das Rufzeichen meiner Gegenstation ins Feld CALL SIGN eingetragen habe. Der voreingestellte Rapport 599 passte. Die Gegenstation gab ihren Namen durch und ich ging also wie immer gleich mit der Maus auf das Feld NAME. Dann trat reproduzierbar jedes mal die Zugriffsverletzung auf, wenn ich das Feld mit Hilfe der Maus betreten wollte; es half nur stattdessen die Tabulator-Taste zu nehmen. Nicht spektakulär genug, um in "The Journal of Irreproducible Results" publiziert zu werden, aber es könnte mit der Navigation, speziell mit dem NAME-Feld zu tun haben.
73
Gerd DJ4KW

Benutzeravatar
DL7UCX
Beiträge: 5360
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: Zugriffsverletzung beim Lesen

Beitrag von DL7UCX » Mittwoch 17. April 2013, 12:16

Hallo Gerd,

die Editor-Komponente für den Namen empfängt (bearbeitet) spezifisch nur 2 Events, OnChange und OnKeyDown, keinerlei Maus-bezogene Events. Lediglich die rechte Maustaste öffnet automatisch das zugeordnete PopUp-Menü.
Auch die übergeordnete Form verarbeitet explizit kein Maus-Event.
Das heißt, alle Maus-Aktionen werden auf der Position des Namens-Feldes ausschließlich von Delphi/Windows verarbeitet.

Ich würde die Fehlerfreiheit eines virtualisierten Betriebssystems :roll: noch deutlich skeptischer sehen als sowieso schon.

73 Ben

dl8dww
Beiträge: 550
Registriert: Mittwoch 1. August 2007, 21:14

Re: Zugriffsverletzung beim Lesen

Beitrag von dl8dww » Montag 19. August 2013, 10:45

Fehler_a.gif
Fehler_a.gif (81.4 KiB) 2794 mal betrachtet
Hallo Ben,
Zugriffsverletzungen treten auch bei mir beim vereinzelt auf. Allerdings nur beim Programmupdate und auch beim Rückfall auf die vorherige Version.
Nach Bestätigen der Meldung gehts ohne Probleme weiter.
73 Wolfgang
Dateianhänge
Fehler.gif
Fehler.gif (84.07 KiB) 2794 mal betrachtet

DL6AU
Beiträge: 36
Registriert: Donnerstag 9. Mai 2013, 20:00
Wohnort: Friedberg (Hessen)

Re: Zugriffsverletzung beim Lesen

Beitrag von DL6AU » Montag 19. August 2013, 14:01

Hallo,

ich kann mich erinnern, dass es bei unseren XP-Rechnern immer wieder Probleme gab, wenn private Software installiert wurde. Häufig kam es durch unsauber programmierte Treiber dazu, dass ganz andere Programme, die mit diesen Treiber gar nichts zu tun hatten, nicht nachvollziehbare Fehler produzierten. In Einzelfällen half nur noch komplette Neuinstallation. :evil:
Vielleicht ist es hier etwas ähnliches.
73 Uwe

Benutzeravatar
DL7UCX
Beiträge: 5360
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: Zugriffsverletzung beim Lesen

Beitrag von DL7UCX » Montag 19. August 2013, 14:19

Hallo,

ich habe den subjektiven Eindruck, daß es nur auf XP-Rechnern vereinzelt zu diesen Problemen beim Programm-Beenden kommt.

73 ben

dl3kvr
Beiträge: 1066
Registriert: Mittwoch 18. November 2009, 10:55

Re: Zugriffsverletzung beim Lesen

Beitrag von dl3kvr » Montag 19. August 2013, 20:36

Nein Ben,
auch bei Win 7, aber relativ selten.
Da ein Ignorieren keine Folgen hatte, war es mir bisher Wurscht.
Früher mit XP und 10 Jahre altem Rechner trat der Effekt regelmäßig auf.
73 Diet

DG1PM
Beiträge: 3
Registriert: Freitag 29. Juni 2018, 07:37

Re: Zugriffsverletzung beim Lesen

Beitrag von DG1PM » Freitag 13. September 2019, 15:19

Hallo zusammen!
Dieser Fehler tritt bei mir seit wenigen Tagen extrem häufig auf, vorher überhaupt nicht. Dann kam das Update auf v. 7.96 und der Fehler kommt immer noch. Wenn ich UcxLog restarte, ist es für einige Stunden ok, kommt aber am selben Tag wieder. Sobald ich im Hauptfenster irgendeinen Menüpunkt anklicke (QSO, Contest, QSL, View..) kommt sofort das popup-fenster (Zugriffsverletzung..). Dann starte ich UcxLog neu und alles ist wieder ok.
Ich nutze den Laptop rein remote via RealVNC für UcxLog, JTDX, WSJT-X. OS ist Win7

73 DG1PM Alex

Benutzeravatar
DL7UCX
Beiträge: 5360
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: Zugriffsverletzung beim Lesen

Beitrag von DL7UCX » Freitag 13. September 2019, 19:45

Hallo Alex,

das dürfte mit UcxLog-Updates nichts zu tun haben, da keine bekannte Fehler vorlagen (und folglich nicht korrigiert wurden).
Ein Fehler, der nach Stunden auftritt und nicht gezielt provoziert werden kann, ist praktisch nicht auffindbar :!:
Da sonst kein User diesen Fehler hat (nur früher beim Beenden in wenigen Fällen), muß ich das auf Deine Konfiguration / Windows / Treiber zurückführen.
"Remote"-Betrieb ist auch schon eine Herausforderung !

73 Ben

dl3kvr
Beiträge: 1066
Registriert: Mittwoch 18. November 2009, 10:55

Re: Zugriffsverletzung beim Lesen

Beitrag von dl3kvr » Samstag 14. September 2019, 19:00

Hallo,
ich kenne diesen Fehler auch.
Aber das nur bei meinen alte Rechnern mit XP.
73 Diet

Antworten