IC 7300 CW!

Moderator: DL7UCX

Antworten
DL4YR
Beiträge: 7
Registriert: Mittwoch 4. September 2019, 20:04

IC 7300 CW!

Beitrag von DL4YR »

Hallo,
ich bin ein relativ neuer UCX-user....
Hat evt. jemand die CW-Einstellungen für einen IC7300 hier für die Software, sowie am TRX oder kann mir bei der richtigen Einstellung behilflich sein?
Ich nutzte in der Testphase bei einigen Contesten UCX-Log und es funktionierte mit "only CW" hervorragend. Seit kurzem aber hakelt die CW-Ausgabe sehr stark. Ich habe weder etwas verändert oder verstellt, woran könnte das liegen?
VIelleicht hat jemand eine brauchbare Lösung....
73 de DL4YR
Ralf

dl8dww
Beiträge: 564
Registriert: Mittwoch 1. August 2007, 21:14

Re: IC 7300 CW!

Beitrag von dl8dww »

Hallo Ralf,
könntest Du bitte das Hakeln etwas näher beschreiben?
73 Wolfgang

Benutzeravatar
DL7UCX
Beiträge: 5618
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: IC 7300 CW!

Beitrag von DL7UCX »

Hallo Ralf,

dann öffne mal den Task-Manager und betrachte die CPU-Last. Die müßte extrem hoch sein, der Verursacher sollte in der Liste sichtbar sein.

73 Ben

DL4YR
Beiträge: 7
Registriert: Mittwoch 4. September 2019, 20:04

Re: IC 7300 CW!

Beitrag von DL4YR »

Hallo Wolfgang,
Zerstückelte abgehackte Zeichen... als wenn die Ausgabe hängen bleibt.
Mit 2 anderen Programmen, die ich noch nutze geht es einwandfrei....

73 de Ralf

dl8dww
Beiträge: 564
Registriert: Mittwoch 1. August 2007, 21:14

Re: IC 7300 CW!

Beitrag von dl8dww »

Hallo Ralf,
eventuell hilft ein Rücksetzen des Transceivers.
Auch eine andere PC-Schnittstelle könnte Abhilfe schaffen.
73 Wolfgang

Benutzeravatar
DL7UCX
Beiträge: 5618
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: IC 7300 CW!

Beitrag von DL7UCX »

Hallo Ralf,

andere Programme können den COM-Port-Treiber beeinträchtigen.
Versuche auch mal Settings - Station - Special: Einschalten "Simple COM port IO method".
Bei Windows 10 bewirkt auch ein "Neu starten" oft Wunder.

73 Ben

DL4YR
Beiträge: 7
Registriert: Mittwoch 4. September 2019, 20:04

Re: IC 7300 CW!

Beitrag von DL4YR »

Hallo Ben,
den Haken zu entfernen hat Abhilfe geschafft, nun läuft alles wieder wie vorher.
Vielen Dank.
73 de DL4YR
Ralf

DL7JOM
Beiträge: 12
Registriert: Montag 11. Januar 2010, 14:40

Re: IC 7300 CW!

Beitrag von DL7JOM »

Hallo Ben,
ich hatte das gleiche Problem (nur mit K3s) und DL1RTL hat mir die Info zu "simple com port io method" gegeben, was macht dieser Schalter?
73 de Olaf, DL7JOM

Benutzeravatar
DL7UCX
Beiträge: 5618
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: IC 7300 CW!

Beitrag von DL7UCX »

Hallo Olaf,

UcxLog verwendet ursprünglich sogenanntes "Overlapped IO", dabei wird das Programm bei einer Ein/Ausgabe auf ein COM-Port nicht bis zur Fertigstellung blockiert, sondern läuft weiter. Da diese Ein-Ausgaben aber meist in einzelnen Hintergrund-Threads laufen, ist mittlerweile auch der "blockierende" Mode machbar, der für Windows und die COM-Port-Treiber etwas einfacher ist.
Notwendig wurde dies nur, weil manche COM-Port-Treiber anscheinend schlecht programmiert sind und u.U. nach Verwendung des "blockierenden" Modes durch andere Programme Schwierigkeiten haben, in den "Overlapped IO" zurückzukehren.

73 Ben

Antworten