INET Zugang

Moderator: DL7UCX

Antworten
DL6AU
Beiträge: 36
Registriert: Donnerstag 9. Mai 2013, 20:00
Wohnort: Friedberg (Hessen)

INET Zugang

Beitrag von DL6AU » Mittwoch 14. August 2013, 07:11

Guten Morgen zusammen,

gibt es irgendwelche Besonderheiten bei der Verbindung von UCX mit dem Internet? Wenn ich meinen Rechner in unserem Intranet betreibe, bekomme ich keine Updatemeldungen. Da ich dieses Problem nicht habe, wenn ich über UMTS gehe, vermute ich, dass das Update entweder über vom Intranet gesperrt Ports erfolgt oder die Adresse gesperrt wird. Eine Fehlermeldung finde ich nicht.
Da ich nur ab und an aus dem Intranet UCX betreibe ist es ist für mich existensbedrohend, trotzdem würde ich gerne den Grund kennen. 8)
73 Uwe

Benutzeravatar
DL7UCX
Beiträge: 5029
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: INET Zugang

Beitrag von DL7UCX » Mittwoch 14. August 2013, 09:17

Hallo Uwe,

das ist ein ganz normaler Internet-URL/File-Zugriff übers Windows-API.
Da der beim Programmstart im Hintergrund erfolgt, werden keine Fehlermeldungen angezeigt.

Wenn Du bei "Update - Online check for updates" das Häkchen wegnimmst und wieder neu setzt (erst Startup abwarten), erfolgt ein Zugriff mit sichtbaren Fehlermeldungen.

73 Ben

DL6AU
Beiträge: 36
Registriert: Donnerstag 9. Mai 2013, 20:00
Wohnort: Friedberg (Hessen)

Re: INET Zugang

Beitrag von DL6AU » Donnerstag 15. August 2013, 07:11

Hallo Ben,

nun ist diese Aussage auch nicht sehr Aufschlussreich :wink:

Internet connection faild:
Der Vorgang wurde erfolgreich beendet.

:lol:
73 Uwe

Benutzeravatar
DL7UCX
Beiträge: 5029
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: INET Zugang

Beitrag von DL7UCX » Donnerstag 15. August 2013, 09:58

Tja, das ist eben Windows :roll:

Die Windows-API-Funktion InternetCheckConnection liefert FALSE zurück, was "not successfully" bedeutet.
Daher macht UcxLog die Mitteilung "Internet connection failed:"

Nähere Auskunft soll die Windows-Funktion GetLastError liefern, deren Antworttext schreibt UcxLog deshalb danach aus.
Dieser lautet augenscheinlich:
"Der Vorgang wurde erfolgreich beendet."

73 Ben

Benutzeravatar
DL7UCX
Beiträge: 5029
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: INET Zugang

Beitrag von DL7UCX » Donnerstag 15. August 2013, 10:11

Hallo Uwe,

mach das bitte nochmal mit 7.30 Beta 10, es gibt zwei Stellen, an denen der Fehler gemeldet werden kann.
Die werden in Beta 10 unterschieden:
"Internet connection failed" oder "Internet opening failed".

73 Ben

DL6AU
Beiträge: 36
Registriert: Donnerstag 9. Mai 2013, 20:00
Wohnort: Friedberg (Hessen)

Re: INET Zugang

Beitrag von DL6AU » Freitag 16. August 2013, 07:38

Hallo Ben,

habe ich gemacht.
Die Meldung ist die gleiche wie vorher

Internet connection failed:
Der Vorgang wurde erfolgreich beendet.
73 Uwe

Benutzeravatar
DL7UCX
Beiträge: 5029
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: INET Zugang

Beitrag von DL7UCX » Freitag 16. August 2013, 08:42

Hallo Uwe,

dann mißlingt gleich der Aufruf von InternetCheckConnection, was wohl einen Ping-Versuch auf http://www.ucxlog.org/ beinhaltet.

73 Ben

Benutzeravatar
DL6ER
Beiträge: 1063
Registriert: Montag 7. März 2011, 21:42
Wohnort: Erftstadt nr Cologne
Kontaktdaten:

Re: INET Zugang

Beitrag von DL6ER » Freitag 16. August 2013, 08:55

Hallo Uwe,

wenn der einfache Ping schon misslingen sollte, wird in deinem Intranet vermutlich das ICMP-Protokoll gesperrt (dieses Protokoll kennt keine Ports wie TCP/UDP).

@Ben: Gäbe es evtl. eine Möglichkeit diesen Schritt zu überspringen und einfach den Download zu versuchen?
Das sollte dann ja eigentlich einer TCP-Anfrage auf Port 80 gleich kommen und die wird wohl nicht gesperrt sein.

73 Dominik

Benutzeravatar
DL7UCX
Beiträge: 5029
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: INET Zugang

Beitrag von DL7UCX » Freitag 16. August 2013, 09:15

Hallo,

ich habe die erste Prüfung mal in 7.31 Beta 1 weggelassen.
Würde sie aber lieber drin behalten, da sonst auch bei völlig fehlendem Internet der Aufbau von Resourcen in WinINet erfolgt.

73 Ben

Benutzeravatar
DL6ER
Beiträge: 1063
Registriert: Montag 7. März 2011, 21:42
Wohnort: Erftstadt nr Cologne
Kontaktdaten:

Re: INET Zugang

Beitrag von DL6ER » Freitag 16. August 2013, 09:40

Hallo Ben,

mal abwarten, ob das Uwes Problem löst.

Wenn ja, kannst du es ja vielleicht als eine weitere der vielen Einstellungsmöglichkeiten unter Settings einbauen, sodass die Umgehung des 1. Checks dann standardmäßig erstmal nicht aktiviert ist, aber im Bedarfsfall aktiviert werden kann.

73 Dominik

DL6AU
Beiträge: 36
Registriert: Donnerstag 9. Mai 2013, 20:00
Wohnort: Friedberg (Hessen)

Re: INET Zugang

Beitrag von DL6AU » Freitag 16. August 2013, 10:45

Hallo Ben, hallo Domenik,

ich werde es mal prüfen. Aber, wie ich schon oben geschrieben habe, geht für mich die Welt nicht unter, wenn es aus dem Intranet nicht klappt. Ersten benutze ich UCX vom Dienstrechner selten und dann nur zur QSL-Kontrolle. Und zweitens kann ich, wenn nötigt, für ein Update über UMTS das Intranet umgehen. Heißt dann eben zwei mal booten.
Das das ICMP-Protokoll gesperrt ist, wäre durchaus denkbar. Da unser Intranet regelmäßigen Angriffen sowohl von außen als von innen ausgesetzt ist, ist alles, was für den normalen Betrieb nicht benötigt wird, gesperrt oder abgeschaltet.

OK Ich melde mich, wenn ich getestet habe.
73 Uwe

DL6AU
Beiträge: 36
Registriert: Donnerstag 9. Mai 2013, 20:00
Wohnort: Friedberg (Hessen)

Re: INET Zugang

Beitrag von DL6AU » Freitag 16. August 2013, 11:44

So, jetzt hatte ich mal Zeit zu testen.

Verbindung klappt jetzt.

Aber Vorsicht: Nun bekomme ich im Telnet Fenster die Fehlermeldung SocketError 10051 angezeigt. Nach einiger Zeit wechselt die Anzeige dann auf Disconnected.
Telnet ist definitiv bei uns gesperrt.

Nicht das durch diese Änderung an anderer Stelle größere Probleme auftreten.
73 Uwe

Benutzeravatar
DL7UCX
Beiträge: 5029
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: INET Zugang

Beitrag von DL7UCX » Freitag 16. August 2013, 20:30

Hallo Uwe,
Verbindung klappt jetzt.
Na dann ist doch alles gut.

Die kleine Änderung betrifft absolut nicht Telnet !
Und wenn Telnet bei Euch gesperrt ist (üblich in Firmennetzen), ist Socket Error 10051 doch nicht falsch.

War denn vorher bei Telnet irgendwas anders?

73 Ben

DL6AU
Beiträge: 36
Registriert: Donnerstag 9. Mai 2013, 20:00
Wohnort: Friedberg (Hessen)

Re: INET Zugang

Beitrag von DL6AU » Samstag 17. August 2013, 17:07

DL7UCX hat geschrieben: War denn vorher bei Telnet irgendwas anders?
Ich denke, dass ich diese Meldung vorher nicht gesehen habe. Beschwören würde ich es aber nicht.

Egal

Danke für die Anpassung
73 Uwe

Antworten