CAT with Ten-Tec Omni VII

Moderator: DL7UCX

Antworten
Benutzeravatar
oz1bii
Beiträge: 28
Registriert: Donnerstag 25. Oktober 2012, 21:14
Kontaktdaten:

CAT with Ten-Tec Omni VII

Beitrag von oz1bii » Montag 28. September 2015, 12:25

Hi
I have installed UcxLog on my friends computer (OZ5KU) but we have some difficulties with the CAT.
He has a Ten Tec Omni VII
CAT working and we can change band on the radio from UcxLog, but UcxLog do not read the frequence from the radio.
Do you have the standard setup for that radio? Xon/Xof - handshake etc.

I see in the Help that you mention something: Ten-Tec Omni can be controlled with menu setting "CdE=ON" as ICOM.
What does that mean ???

The radio works perfect together with HRD program.
73 de OZ1BII/OU2I Henning
CW is all I need

Benutzeravatar
DL7UCX
Beiträge: 5038
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: CAT with Ten-Tec Omni VII

Beitrag von DL7UCX » Montag 28. September 2015, 17:49

Hello Henning,

I found these RS-232 settings:
57600 baud, No parity, 8 Data bits, 1 Stop bit, Hardware RTS/CTS.

If this not helps, set in UcxLog menu "Help - Trace system events - TRX control".
Start UcxLog and Omni, switch band/mode.
You will find a file SYSLOG.TXT in the log data directory, send me this file please.

I think "CdE = ON" means a value in the Omni settings, I do not find a real useful Omni manual in the moment.

73 Ben

Benutzeravatar
oz1bii
Beiträge: 28
Registriert: Donnerstag 25. Oktober 2012, 21:14
Kontaktdaten:

Re: CAT with Ten-Tec Omni VII

Beitrag von oz1bii » Dienstag 29. September 2015, 07:44

Thanks so far Ben - I will return.
73 de OZ1BII/OU2I Henning
CW is all I need

Benutzeravatar
oz1bii
Beiträge: 28
Registriert: Donnerstag 25. Oktober 2012, 21:14
Kontaktdaten:

Re: CAT with Ten-Tec Omni VII

Beitrag von oz1bii » Freitag 2. Oktober 2015, 08:18

Log sent.

When using "Auto detect" in UcxLog, it finds the radio and set 56000 bd. UcxLog can send data.
If changing to your data with 57600 bd it do exactly the same.
Weird that it "speaks" with both baud rates :o)
73 de OZ1BII/OU2I Henning
CW is all I need

Benutzeravatar
DL7UCX
Beiträge: 5038
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: CAT with Ten-Tec Omni VII

Beitrag von DL7UCX » Freitag 2. Oktober 2015, 09:36

Yes, the difference between the 2 baudrates is only 3%. So the asynchron protocol will find the right bits in both cases.
UcxLog auto-detect can only look for "Success" of communication, so it takes the first working baud rate.
Set the right baud rate manual.

Pse qrx, I'm analysing your syslog file. There seems to be a difference in a CAT command.

73 Ben

Benutzeravatar
oz1bii
Beiträge: 28
Registriert: Donnerstag 25. Oktober 2012, 21:14
Kontaktdaten:

Re: CAT with Ten-Tec Omni VII

Beitrag von oz1bii » Dienstag 13. Oktober 2015, 15:43

Hi Ben
I am at the station now and trying different Things.

When starting the program, the radio always goes to LSB.
When changing mode in the program, the radio do not shift to the correct mode.
When I choose CW mode in program, the radio goes in LSB.
When shifting mode on radio, nothing happens in the program.

Shall I send a new LOG ??


Command: Set/Get MODE
Set Format Query Format: *M VFOA VFOB<CR> ?M <CR>
Set Note Query return val: VFOA/B=ASCII ‘0’ .. ‘6’ M VFOA VFOB <CR>

Command: Get Mode Orion Form
Set Format Query Format: ?RMM <CR>
Set Note Query return val: @RMM <d0> <CR>

Programmers reference Omni VII Model 588
http://www.rkrdesignsllc.com/static/med ... v1.009.pdf

What do you say Ben ?
73 de OZ1BII/OU2I Henning
CW is all I need

Benutzeravatar
DL7UCX
Beiträge: 5038
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: CAT with Ten-Tec Omni VII

Beitrag von DL7UCX » Dienstag 13. Oktober 2015, 15:52

Hello Henning,

Is frequency control working now?
Yes, please sent SYSLOG.TXT and write, which modes you set in UcxLog.

73 Ben

UcxLog uses
Get Mode: ?M <CR>
Set Mode: *M VFOA VFOB<CR>

e.g. "3" = CW :arrow: *M33<CR>

Before I used
Get Mode Orion Form: ?RMM <CR>
but it was not working.

Benutzeravatar
oz1bii
Beiträge: 28
Registriert: Donnerstag 25. Oktober 2012, 21:14
Kontaktdaten:

Re: CAT with Ten-Tec Omni VII

Beitrag von oz1bii » Dienstag 13. Oktober 2015, 16:04

Yes frequence shifty Works, but when shifting frq the mode on the radio also shifts - allways to LSB - but showing CW mode in program.

When shift to SSB in program radio goes to AM.
73 de OZ1BII/OU2I Henning
CW is all I need

Benutzeravatar
DL7UCX
Beiträge: 5038
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: CAT with Ten-Tec Omni VII

Beitrag von DL7UCX » Dienstag 13. Oktober 2015, 16:46

I got the SYSLOG.
It is difficult to analyse if you record 6 minutes.

I see mode changes to "2" (LSB) and to "0" (AM), send from UcxLog to TRX.
TRX gets back exactly the set mode.
I don't know why mode "LSB" is sent and you say, you set it to "CW".
This mode handling is the same for all TRX, never it was a problem.
Where do you set the mode?
In the QSO Work window?

Please do again this:
Delete SYSLOG.TXT
Start UcxLog and TRX.
Go to 20m band.
Set in UcxLog Work Window only these modes with 5 seconds interval :
CW
SSB
AM
FM
CW
Close UcxLog, send SYSLOG.TXT.

73 Ben

By the way, there are many responses from TRX missing. Is the baud rate set exactly?

Benutzeravatar
DL7UCX
Beiträge: 5038
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: CAT with Ten-Tec Omni VII

Beitrag von DL7UCX » Dienstag 13. Oktober 2015, 16:51

Sri, Modes of Omni are wrong, pse qrx ...

Mode CAT codes of Orion and Omni are totally different :shock:

Pse wait for new version ...

Benutzeravatar
oz1bii
Beiträge: 28
Registriert: Donnerstag 25. Oktober 2012, 21:14
Kontaktdaten:

Re: CAT with Ten-Tec Omni VII

Beitrag von oz1bii » Dienstag 13. Oktober 2015, 17:11

OK Ben.

We wait for 7.54.2 ?
73 de OZ1BII/OU2I Henning
CW is all I need

Benutzeravatar
DL7UCX
Beiträge: 5038
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: CAT with Ten-Tec Omni VII

Beitrag von DL7UCX » Dienstag 13. Oktober 2015, 17:13

I exchanged the 2 mode commands of Omni but did not detect, that the mode codes are different, sri.
Please try UcxLog version 7.54 Beta 1.

73 Ben

Benutzeravatar
oz1bii
Beiträge: 28
Registriert: Donnerstag 25. Oktober 2012, 21:14
Kontaktdaten:

Re: CAT with Ten-Tec Omni VII

Beitrag von oz1bii » Dienstag 13. Oktober 2015, 17:16

BEN !!!

Works with 7.54 Beta 1 !!!

I will make a logfile and send to you in a minute.
73 de OZ1BII/OU2I Henning
CW is all I need

Benutzeravatar
DL7UCX
Beiträge: 5038
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: CAT with Ten-Tec Omni VII

Beitrag von DL7UCX » Dienstag 13. Oktober 2015, 17:23

If it works I do not need a log file :D

Benutzeravatar
oz1bii
Beiträge: 28
Registriert: Donnerstag 25. Oktober 2012, 21:14
Kontaktdaten:

Re: CAT with Ten-Tec Omni VII

Beitrag von oz1bii » Dienstag 13. Oktober 2015, 18:47

Thank you Ben !

I think OZ5KU will ask for a license when the 40 days he has left, are over.
Best 73 de OZ1BII Henning
73 de OZ1BII/OU2I Henning
CW is all I need

Antworten