CAT TS-480

Moderator: DL7UCX

Antworten
Benutzeravatar
DL6ER
Beiträge: 1064
Registriert: Montag 7. März 2011, 21:42
Wohnort: Erftstadt nr Cologne
Kontaktdaten:

CAT TS-480

Beitrag von DL6ER » Freitag 26. Juni 2015, 15:01

Hallo zusammen,

vor einiger (längerer) Zeit ist bei mir die Verbindung zwischen UcxLog und meinem TS-480 teilweise ausgefallen. Teilweise soll heißen, dass es eine Einbahnstraße geworden ist: Steuerbefehle an den TRX funktionieren, aber Frequenzänderungen am TRX werden nicht von diesem zurückgemeldet, das Feld wird/bleibt gelb.

Heute bin ich dem nachgegangen und habe testweise das serielle Kabel sowie den USB/Seriell-Wandler ausgetauscht. Siehe da: Der Wandler scheint Okay, aber das Kabel brachte einen Unterschied.

Bei DTR/RTS High ist das Feld jetzt weiß, Frequenzänderungen werden aber trotzdem nicht zurückgemeldet. Senden an TRX geht.
SYSLOG.TXT hat geschrieben:12:53-13.495 TRX 1 - Sent Status Request : 49 46 3B
12:53-13.495 TRX 1 - Sent completed.
12:53-13.503 TRX 1 - Data block received: 00 04 20 20 20 20 20 30 20 20 20 20 20 00 00 00 00 00 00 20 20 20 20 20 20 20 20 20 20 20 20 20 20 20 20 30 20 32
12:53-13.755 TRX 1 - Receive timeout:
Bei DTR/RTS Low habe ich wieder die vorherige Einbahnstraße. Das Feld ist gelb, aber das Senden an TRX geht auch.
SYSLOG.TXT hat geschrieben:12:54-41.994 TRX 1 - Sent Status Request : 49 46 3B
12:54-41.995 TRX 1 - Sent completed.
12:54-42.084 TRX 1 - Receive timeout:
12:54-42.335 TRX 1 - Receive timeout:
Was meint Ihr? Da etwas ankommt, glaube ich, dass das neue Kabel funktioniert. Ich habe leider kein Drittes vor Ort.

73 de Dominik

Benutzeravatar
DL7UCX
Beiträge: 5063
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: CAT TS-480

Beitrag von DL7UCX » Freitag 26. Juni 2015, 15:13

Hallo Dominik,

der TS-480 braucht unglücklicherweise das eingehende Steuersignal auf HIGH, deswegen geht es nur mit DTR/RTS= HIGH oder der Brücke am RS232-TRX-Stecker.
Die zurückgemeldeten Daten sind allerdings Unfug, da stehen ja vorwiegend nur Leerzeichen (20hex) drin.

73 Ben

Benutzeravatar
DL6ER
Beiträge: 1064
Registriert: Montag 7. März 2011, 21:42
Wohnort: Erftstadt nr Cologne
Kontaktdaten:

Re: CAT TS-480

Beitrag von DL6ER » Freitag 26. Juni 2015, 15:26

Hallo Ben,

ich habe das Problem "lösen" oder sagen wir lieber umgehen können, indem ich die Baudrate an TRX und PC auf 4800 reduziert habe :shock: ...
SYSLOG.TXT hat geschrieben: 13:23-23.787 TRX 1 - Sent Status Request : 49 46 3B
13:23-23.788 TRX 1 - Sent completed.
13:23-23.831 TRX 1 - Data block received: 49 46 30 30 30 32 38 30 31 35 31 36 30 20 20 20 20 20 20 30 30 31 30 30 30 30 30 30 30 33 30 30 30 30 30 38 30 3B
13:23-24.082 TRX 1 - Receive timeout:
Warum höhere Baudraten nicht mehr funktionieren, kann ich mir nicht erklären. Dieses beobachtete Verhalten habe ich mit zwei PCs mit jeweils zwei USB/Seriell-Wandlern (unterschiedlicher Chipsatz, unterschiedliche Preisklasse) bestätigen können, es wird also wohl an meinem TS-480 liegen :cry: .

Danke für die Info bzgl. dem DTR/RTS High.

73 Dominik

dl8dww
Beiträge: 536
Registriert: Mittwoch 1. August 2007, 21:14

Re: CAT TS-480

Beitrag von dl8dww » Freitag 26. Juni 2015, 16:16

Hallo Dominik,
Schlechte und/oder zu lange Kabel sind mitunter die Ursache, daß die Signalflanken nicht sauber genug sind.
Da hilft besseres Material und eine niedrige Baudrate.
Ein ähnliches Problem hatte ich unlängst mit einem USB-Stick. Da lg es auch am Verbindungskabel
73 Wolfgang

Benutzeravatar
DL6ER
Beiträge: 1064
Registriert: Montag 7. März 2011, 21:42
Wohnort: Erftstadt nr Cologne
Kontaktdaten:

Re: CAT TS-480

Beitrag von DL6ER » Freitag 26. Juni 2015, 16:21

Hallo Wolfgang,

ich fürchte, dass das hier nicht zutrifft. Das Kabel ist verhältnismäßig hochwertig und 9600baud ist auch eigentlich derartig langsam, dass man das sogar im Freiraum per Schall übertragen könnte... USB ist da schon ein ganz anderes Kaliber.

73 Dominik

Benutzeravatar
DL7UCX
Beiträge: 5063
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: CAT TS-480

Beitrag von DL7UCX » Sonntag 28. Juni 2015, 20:03

Hallo Domink,

ich würde auch vermuten, daß es am TS-480 liegt, ich hatte noch nie Probleme dieser Art.
4800 Bd sind für die CAT-Steuerung des TS-480 aber schnell genug, damit kannst Du leben, wenn es nicht schlechter wird.

73 Ben

DL1DTL
Beiträge: 736
Registriert: Donnerstag 12. September 2002, 09:44
Wohnort: Dresden

Re: CAT TS-480

Beitrag von DL1DTL » Montag 29. Juni 2015, 12:52

Hi Dominik,

mein TS940 wird auch mit 4800 Bd betrieben. Ich könnte mir vorstellen, dass das der 480 auch erwartet.

Klaus

Benutzeravatar
DL6ER
Beiträge: 1064
Registriert: Montag 7. März 2011, 21:42
Wohnort: Erftstadt nr Cologne
Kontaktdaten:

Re: CAT TS-480

Beitrag von DL6ER » Montag 29. Juni 2015, 13:09

Hallo Klaus,

man kann die Baudrate im Menü einstellen. Ich bin aber soweit mit 4800baud zufrieden. 9600baud, 8N1 ist die Voreinstellung.

Nachtrag: Bei nächster Gelegenheit (Ende Juli?) werde ich mir einen Zwischenstecker basteln und die Signalflanken mit dem Oszilloskop untersuchen...

73 Dominik
Dateianhänge
Screenshot-13.png
Bedienungsanleitung, Beschreibung Menüfunktionen
Screenshot-13.png (23.8 KiB) 1624 mal betrachtet

DL1DTL
Beiträge: 736
Registriert: Donnerstag 12. September 2002, 09:44
Wohnort: Dresden

Re: CAT TS-480

Beitrag von DL1DTL » Montag 29. Juni 2015, 17:41

Hi Dominik,

ok, beim TS940 mit dem IF10B ist 4800 Bd vorgeschrieben. Das steht aber nur in der Beschreibung zum IF10.

Ist eben ein altes Gerät :mrgreen:

73 Klaus

dl8dww
Beiträge: 536
Registriert: Mittwoch 1. August 2007, 21:14

Re: CAT TS-480

Beitrag von dl8dww » Montag 29. Juni 2015, 18:21

Hallo Dominik,
mit HTERM.exe , ein Freeware-Terminalprogramm, kannst Du das Arbeiten der Schnittstelle vom TS 440 überprüfen.
so gehts:
HTERM.exe starten, Parameter der COM einstellen.
TRX einschalten, aber nicht UCXLog starten.
Button. "Connect" betätigen.
unten im Terminalfenster IF; ( ein Lesekommando) eingaben.
der KWD sedet die Info.
Wenn das mit 4K8 Bd geht, dann einfach auf 9K6 wechseln und das Gleiche noch einmal.

73 Wolfgang

Benutzeravatar
DL6ER
Beiträge: 1064
Registriert: Montag 7. März 2011, 21:42
Wohnort: Erftstadt nr Cologne
Kontaktdaten:

Re: CAT TS-480

Beitrag von DL6ER » Sonntag 2. August 2015, 01:16

Hallo zusammen,

leider geht meine Geschichte hier doch noch weiter. Während meiner sporadischen Teilnahme am heutigen Contest ist das Frequenzfeld wieder gelb geworden. :(
Tiefer als 4800baud kann der TX-480 nicht mehr gehen. Da bleibt mir wohl nichts mehr anderes übrig, als mir die Signale nun wirklich per Oszi anzuschauen - auch wenn ich noch nicht weiß was mir das bringen könnte.

@Wolfgang: Das genannte Programm habe ich versucht, jedoch ohne Erfolg. Die Liste der zur Verfügung stehenden Schnittstellen ist und bleibt auch bei Klick auf "R" leer... Eine manuelle Eingabe von COM7 oder COM8 (das sind meine beiden angesteckten USB/Seriell-Wandler) bringt auch keinen Erfolg.

Nachtrag:
Langsam beginne ich wirklich an mir selbst zu zweifeln...
Ich habe die Baudrate (nachdem es bei 4800 nicht funktioniert hat) an TRX und PC erhöht. Danach habe ich sie wieder erniedrigt und siehe da ... die Kommunikation funktioniert wieder. Die Flanken der Antwort vom TS-480 sehen einwandfrei aus (aber jetzt funktioniert es ja auch wieder...).

73 Dominik

Antworten