DLPortio

Moderator: DL7UCX

Benutzeravatar
DL7UCX
Beiträge: 5054
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: DLPortio

Beitrag von DL7UCX » Mittwoch 11. Februar 2015, 18:22

Hallo Wolfgang,

die Fehlermeldung kam wohl von Windows, dort vermute ich auch das Treiberproblem.
Ob UcxLog LPT erkennt, kann er natürlich probieren.
Deaktivieren der Rotorsteuerung dürfte nicht nötig sein, die LPT ist nicht exclusiv genutzt.

73 Ben

dl3nbl
Beiträge: 71
Registriert: Samstag 21. Januar 2012, 17:52

Re: DLPortio

Beitrag von dl3nbl » Donnerstag 12. Februar 2015, 18:31

Hallo Ben, Hallo Wolfgang,

danke für eure Nachrichten.
Ich arbeite mit einem Yaesu-Rotor RC-5B-3
Das Modem ist von EA4TX. Das habe ich selbst aufgebaut und hat bis jetzt super fuktioniert.
Die Software ist "Arswin" und eben auch von dem EA4TX.
Die LPT - Schnittstelle wird von UCX erkannt und wie schon geschrieben, hat auch alles bestens gefunzt.
Aber dann kam diese Meldung "DLPORTIO.SYS device driver not loaded. Port I/O will have no effect".
Eben weil das so gut gearbeitet hat, hätte ich halt gerne, daß es wieder so wird.......

73, gerhard

Benutzeravatar
DL7UCX
Beiträge: 5054
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: DLPortio

Beitrag von DL7UCX » Donnerstag 12. Februar 2015, 18:57

Hallo Gerhard,

sri, nach 17 Beiträgen weiß ich immer noch nicht richtig, was mit der LPT gemacht wird.
Wenn der Rotor über ARSWIN gesteuert wird, benutzt UcxLog keine LPT-Schnittstelle.
UcxLog kann mit der ARSWIN-Software über Windows kommunizieren.
Benutzt ARSWIN die LPT-Schnittstelle zum Rotor-Interface?
Insofern verstehe ich nicht, was eigentlich wann genau gefunzt hat:
Die LPT - Schnittstelle wird von UCX erkannt und wie schon geschrieben, hat auch alles bestens gefunzt.
73 Ben

dl3nbl
Beiträge: 71
Registriert: Samstag 21. Januar 2012, 17:52

Re: DLPortio

Beitrag von dl3nbl » Samstag 14. Februar 2015, 16:18

Hallo Ben,

ich will eigentlich nur wissen, ob hier jemand schon mal diese Fehlermeldung erhalten hat und mir evtl. schreiben kann, was ich da tun kann um die Funktion wieder herzustellen.
UCX-Log zeigt halt an unter "Setting" dass die LPT-Schnittstelle frei ist, das hat der Wolfgang wissen wollen.
Gesteuert wird natürlich das Ganze über dieses Modem von dem EA4TX und seiner Arswin Software.

73, gerhard

Benutzeravatar
DL7UCX
Beiträge: 5054
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: DLPortio

Beitrag von DL7UCX » Samstag 14. Februar 2015, 16:36

Hallo Gerhard,

wenn UcxLog die LPT-Schnittstelle in Settings-Station als "vorhanden" anzeigt ("belegt von anderen" kann es nicht erkennen),
dann ist das Port real zugreifbar, d.h. Schreiben und Lesen funktioniert über die DLPORTIO.DLL :!:

Die Port-Nummer muß nicht stimmen, die zählt jeder anders.

73 Ben

dl3nbl
Beiträge: 71
Registriert: Samstag 21. Januar 2012, 17:52

Re: DLPortio

Beitrag von dl3nbl » Samstag 28. Februar 2015, 12:26

Ok, Ben.
Vielen Dank für die Infos.
73 de gerhard

Benutzeravatar
DL7UCX
Beiträge: 5054
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: DLPortio

Beitrag von DL7UCX » Montag 28. Dezember 2015, 17:09

Hallo,

es gibt einen LPT-Treiber, der mit allen Windows-Versionen funktionieren soll: inpout32.dll

Der wird von UcxLog Version 7.56 Beta 15 unterstützt, ich konnte es unter Windows 7 aber nicht probieren (kein LPT).

Installation:
http://www.ucxlog.com/inpout32.dll ins Programmverzeichnis downloaden, alle DLPORTIO-Files entfernen.
Beim ersten UcxLog-Start wird er installiert, dazu muß UcxLog einmalig mit Administrator-Rechten gestartet werden.

Bei Erfolg steht im Fenster "Start Up Messages" in der 1. Zeile: "LPT port: inpout32.dll loaded.".

73 Ben

P.S.: TNX für den Tip an DL8PG

dl8dww
Beiträge: 535
Registriert: Mittwoch 1. August 2007, 21:14

Re: DLPortio

Beitrag von dl8dww » Dienstag 29. Dezember 2015, 14:55

Hallo Ben,

ich habe unter XP SP3 und WIN7 32Bit probiert.Bei beiden Betriebssystemen wird durch UCXLog die LPT erkannt
Beim Win7-PC ist es der USB/LPT-Wandler (Eigenbau mit Atmega8) und bei der XP-Kiste ist eine echte LPT.

73 Wolfgang
Zuletzt geändert von dl8dww am Dienstag 29. Dezember 2015, 15:50, insgesamt 1-mal geändert.

Benutzeravatar
DL7UCX
Beiträge: 5054
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: Ablösung DLPortio durch inpout32.dll

Beitrag von DL7UCX » Dienstag 29. Dezember 2015, 14:58

Hallo Wolfgang,

danke, dann werde ich das auch so in die Help aufnehmen.
Der DLPortio sollte somit überflüssig sein.

73 Ben

Antworten