DLPortio

Moderator: DL7UCX

dl3nbl
Beiträge: 69
Registriert: Samstag 21. Januar 2012, 17:52

DLPortio

Beitrag von dl3nbl » Donnerstag 5. Februar 2015, 10:54

Hallo,
mein Problem:
"DLPORTIO.SYS device driver not loaded. Port I/O will have no effect"
Ich verwende schon lange XP als Betriebssystem und steuere meinen Rotor über die Parallele Schnittstelle.
Hat bis vor kurzem immer einwandfrei funktioniert. Aber nun kommt beim hochfahren des PC`s immer diese Fehlermeldung.
Was kann das sein und wer kann mir evtl. helfen ?
Vielen Dank im vorraus.

73, gerhard, dl3nbl

Benutzeravatar
DL7UCX
Beiträge: 5038
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: DLPortio

Beitrag von DL7UCX » Donnerstag 5. Februar 2015, 11:20

Hallo Gerhard,

hast Du schon mal hier im Forum auf "Suche" geklickt und "DLPORTIO" eingegeben?
Da kommt genug zum Lesen ...

Die Fehlermeldung stammt direkt aus Windows.
Ich würde als erstes den DLPORTIO im Windows neu installieren.

73 Ben

dl3nbl
Beiträge: 69
Registriert: Samstag 21. Januar 2012, 17:52

Re: DLPortio

Beitrag von dl3nbl » Donnerstag 5. Februar 2015, 13:13

Hallo Ben,
Danke für die Antwort.
Ich habe dieses schon gemacht. Ich habe auch schon hier alles durchgeforstet, sowie auch im Internet gegoogelt,
aber alles was ich getan habe bringt nichts.
Deswegen meine Frage hier nochmal....vieleicht ist hier doch noch jemand, dem das ebenfalls schon passiert ist...
Ich weiss dass das alles eine "alte" Technik ist, aber es wäre halt schön wenn das wieder klappen würde.

73, gerhard

dl8dww
Beiträge: 535
Registriert: Mittwoch 1. August 2007, 21:14

Re: DLPortio

Beitrag von dl8dww » Donnerstag 5. Februar 2015, 17:15

Hallo Gerhard,
diese Meldung ist mir noch nicht über den Weg gelaufen.
Gibt es eventuell in System Verwaltung einen Hinweis zu diesem Problem?
73 Wolfgang

dl3nbl
Beiträge: 69
Registriert: Samstag 21. Januar 2012, 17:52

Re: DLPortio

Beitrag von dl3nbl » Donnerstag 5. Februar 2015, 18:05

Hallo Wolfgang,
Sorry, ich finde da nichts darüber.
Hast du vieleicht eine Ahnung, was das sein könnte ?

73, gerhard

dl8dww
Beiträge: 535
Registriert: Mittwoch 1. August 2007, 21:14

Re: DLPortio

Beitrag von dl8dww » Donnerstag 5. Februar 2015, 20:53

Hallo Gerhard,
DLPORTIO ist schon etwas geheimnisvoll.
Hatte versucht das gleiche Verhalten wie bei Dir hinzubekommen.
Hatte im WIN32-Verzeichnis die DLPORTIO.DLL umbenannt. Das Ergebnis war, daß UCXLOG die LPT nicht mehr erkannt hat. In der Windows Systemsteuerung gab es noch eine LPT. Als Nächstes wurde DLPORTIO.SYS umbenannt. Hätte eigentlich dazu führen müssen, das auch in der Systemsteuerung keine LPT mehr da ist.
Dem war aber nicht so. Da sitzt bestimmt noch was in der Registry ?
Vor längerer Zeit hatte ich unter WIN7,32 Bit eine LPT zum Laufen gebracht. Funktioniert mit einer anderen DLL.
Die kann sogar im UCXLOG-Verzeichnis liegen und muß nicht einmal ins system32.
Diese DLL könntest Du mal probieren. Ich müsste nur Dein Mail wissen, damit Du diese bekommen kannst
Mehr an Ideen habe ich im Moment auch nicht
Wird die LPT bei Dir in der Systemsteuerung erkannt?
73 Wolfgang

dl3nbl
Beiträge: 69
Registriert: Samstag 21. Januar 2012, 17:52

Re: DLPortio

Beitrag von dl3nbl » Samstag 7. Februar 2015, 16:52

Hallo Wolfgang,
danke für deine Nachricht.
die LPT wird in der Systemsteuerung erkannt.
Meine E-mailadresse ist: dl3nbl@t-online.de
73, gerhard

Benutzeravatar
DL7UCX
Beiträge: 5038
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: DLPortio

Beitrag von DL7UCX » Samstag 7. Februar 2015, 17:06

Hallo Gerhard,

wenn ich das richtig sehe, hat die Rotorsteuerung über LPT nichts mit UcxLog zu tun.
Kannst Du Deinen Rotor nicht über eine der UcxLog-Rotorinterface-Varianten steuern ?
Dieses LPT-Interface ist doch eine Sackgasse.

73 Ben

dl8dww
Beiträge: 535
Registriert: Mittwoch 1. August 2007, 21:14

Re: DLPortio

Beitrag von dl8dww » Samstag 7. Februar 2015, 17:15

Hallo Gerhard,
die DLL ist auf dem Weg zu Dir.
Bin gespannt, ob es hilft.
Unabhängig vom Ergebnis würde ich Dir das Expandio-Interface von Ben als Ersatz für die LPT empfehlen.
Habe es selbst aufgebaut und damit meine Antennenumschaltung realisiert. Da müsste auch die Rotorsteuerung damit machbar sein.
73 Wolfgang

Benutzeravatar
DL7UCX
Beiträge: 5038
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: DLPortio

Beitrag von DL7UCX » Samstag 7. Februar 2015, 17:19

Es ist keine Rotorsteuerung bei dem ExpandIO-Interface vorgesehen.

73 Ben

dl3nbl
Beiträge: 69
Registriert: Samstag 21. Januar 2012, 17:52

Re: DLPortio

Beitrag von dl3nbl » Mittwoch 11. Februar 2015, 10:59

Hallo Wolfgang, Hallo Ben,
Danke für eure Bemühungen.
Wolfgang deine dll hat leider nicht funktioniert, schade.
Was würdet ihr mir raten was ich tun soll ???

73 de gerhard

Benutzeravatar
DL7UCX
Beiträge: 5038
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: DLPortio

Beitrag von DL7UCX » Mittwoch 11. Februar 2015, 13:31

Hallo Gerhard,

was für einen Rotor mit welchem Interface und welcher Steuersoftware hast Du denn :?:

73 Ben

Nachtrag:
Ich hatte gute Erfahrungen mit "Easy Rotor Control" gemacht, steuere jetzt aber den Yaesu-Rotor über den Yaesu-TRX ohne weiteres Interface aus UcxLog.

dl8dww
Beiträge: 535
Registriert: Mittwoch 1. August 2007, 21:14

Re: DLPortio

Beitrag von dl8dww » Mittwoch 11. Februar 2015, 14:00

wird die LPT durch UCXLog erkannt?
73 Wolfgang

Benutzeravatar
DL7UCX
Beiträge: 5038
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: DLPortio

Beitrag von DL7UCX » Mittwoch 11. Februar 2015, 14:01

Welche LPT ?

dl8dww
Beiträge: 535
Registriert: Mittwoch 1. August 2007, 21:14

Re: DLPortio

Beitrag von dl8dww » Mittwoch 11. Februar 2015, 18:07

Hallo Ben,
wenn Gerhard seine Rotorsteuerung über LPT realisiert, dann müsste diese Schnittstelle auch von UCXLog erkennt werden. Voraussetzung ist, daß er seine Rotorsteuerung deaktiviert. Wenn die LPT von UCXLog erkannt würde, liegt die Ursache u.U. bei der Rotorsteuerungssoftware. Oder liege ich da falsch?
73 Wolfgang

Antworten