DL6ER-Keyer

Moderator: DL7UCX

Benutzeravatar
DL6ER
Beiträge: 1063
Registriert: Montag 7. März 2011, 21:42
Wohnort: Erftstadt nr Cologne
Kontaktdaten:

Re: DL6ER-Keyer

Beitrag von DL6ER » Dienstag 13. Januar 2015, 10:09

Hallo zusammen,

@Thomas: Ja, genau das ist mein Hersteller meines Vertrauens... Sehr gute Qualität und der Preis sucht seines Gleichen. Außerdem ist der Service 1A. Bei meinen bisherigen Bestellungen haben ich fast immer mehr Platinen zum gleichen Preis erhalten. Offensichtlich wird vorhandener Platz auf den Platinenrohlingen gerade bei Bestellung kleiner Platinen immer ausgenutzt ohne dass es dem Kunden dann zusätzlich berechnet wird.

Preis: Hier bezahle ich etwa 30 Euro, habe dann aber aufgrund der Mindestabnahmemenge auch gleich 3 Platinen.

Problem: Seit Anfang Dezember (!) ist niemand mehr dort erreichbar, Telefonanrufe und E-Mails bleiben unbeantwortet. Abgegebene Aufträge werden mit einer automatischen Mail quittiert, dass man innerhalb von 48h eine Auftragsbestätigung erhalten würde. Leider passiert aber überhaupt nichts.
Nachforschungen verlaufen im Leeren, die Webseite ist völlig okay, Hinweise auf Insolvenz, etc. habe ich keine gefunden.
Es gibt aber scheinbar auch einen eBay-Shop. Dort ist am 1. September 2014 der letzte Artikel ausgelaufen, seitdem völlige Funkstille. :cry:

@Maik: Die wollen ca. 50 Euro für eine Platine, für 3 Platinen werden ca. 110 Euro fällig.
Dazu noch Versand ... das ist mir zu teuer.

73 Dominik

Benutzeravatar
DL6ER
Beiträge: 1063
Registriert: Montag 7. März 2011, 21:42
Wohnort: Erftstadt nr Cologne
Kontaktdaten:

Re: DL6ER-Keyer

Beitrag von DL6ER » Samstag 17. Januar 2015, 21:13

Update:
Nach ein paar Rückfragen hat die Clubstation der Universität, DK0UN, ein Nutzungsrecht der "Rapid Prototyping"-Maschine von LPKF in deren Leerlaufzeiten erhalten.
Jetzt sind noch Feinheiten wie benötigte Dateiformate abzuklären, aber dann geht es hier hoffentlich bald weiter.

73 Dominik

Benutzeravatar
DL6ER
Beiträge: 1063
Registriert: Montag 7. März 2011, 21:42
Wohnort: Erftstadt nr Cologne
Kontaktdaten:

Re: DL6ER-Keyer

Beitrag von DL6ER » Donnerstag 22. Januar 2015, 19:30

Okay,

Prototyp gestern aufgebaut und soweit funktioniert alles.

@Ben: Mir ist beim Testen aufgefallen, dass die Relaisdaten bei der Initialisierung nicht gesendet werden.
Somit bleiben nach einem frischen Start alle Relais auf Null, bis der Nutzer das erste mal das Band wechselt.

Ansonsten einwandfrei.

73 Dominik

Benutzeravatar
DL7UCX
Beiträge: 5053
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: DL6ER-Keyer

Beitrag von DL7UCX » Freitag 23. Januar 2015, 09:37

Hallo Dominik,

probier mal bitte Beta 9. Dort sollte nach dem 0F-Kommando die Initialisierung erfolgen.

73 Ben

Benutzeravatar
DL6ER
Beiträge: 1063
Registriert: Montag 7. März 2011, 21:42
Wohnort: Erftstadt nr Cologne
Kontaktdaten:

Re: DL6ER-Keyer

Beitrag von DL6ER » Samstag 24. Januar 2015, 15:06

Hallo Ben,

ja, aber nur teilweise. Wenn ich nun UcxLog neu starte, werden die Relaisdaten wie erwartet übertragen.

Code: Alles auswählen

14:03-09.942  WinKey - Send: 7F 7F 13 13 13 13 00 04 55 
14:03-09.943  Winkey - Sent completed.
14:03-09.944  WinKey received: 7F
14:03-09.945  DL6ER-Keyer detected
14:03-09.945  WinKey received: 55
14:03-09.946  WinKey - Send: 00 02 
14:03-09.946  Winkey - Sent completed.
14:03-09.948  WinKey received: 23
14:03-09.949  WinKey - Send: 0F 14 18 05 32 05 00 08 20 00 00 0A 32 32 04 FF 07 15 
14:03-09.949  Winkey - Sent completed.
14:03-09.950  WinKey received: 98
14:03-09.950  WinKey received: C0
14:03-09.951  WinKey received: 98
14:03-09.952  WinKey received: C0
14:03-09.986  WinKey - Send: 09 05 
14:03-09.987  Winkey - Sent completed.
14:03-10.457  WinKey timeout
14:03-10.483  WinKey - Send: 7F 03 FF 
14:03-10.484  Winkey - Sent completed.
Wenn ich aber bei bereits laufendem UcxLog den COM-Port ändere, werden die Daten bei der darauf folgenden Initialisierung nicht übertragen.
Dabei ist mir auch aufgefallen, dass das 09 05 nicht übertragen wird (Winkey Pinconfig).

Code: Alles auswählen

14:00-18.420  WinKey - Send: 7F 7F 13 13 13 13 00 04 55 
14:00-18.420  Winkey - Sent completed.
14:00-18.422  WinKey received: 7F
14:00-18.422  DL6ER-Keyer detected
14:00-18.423  WinKey received: 55
14:00-18.424  WinKey - Send: 00 02 
14:00-18.424  Winkey - Sent completed.
14:00-18.426  WinKey received: 23
14:00-18.426  WinKey - Send: 0F 14 18 05 32 05 00 08 20 00 00 0A 32 32 05 FF 07 15 
14:00-18.427  Winkey - Sent completed.
14:00-18.427  WinKey received: 98
14:00-18.428  WinKey received: C0
14:00-18.429  WinKey received: 98
14:00-18.430  WinKey received: C0
14:00-18.932  WinKey timeout
14:00-19.433  WinKey timeout
14:00-19.935  WinKey timeout
14:00-20.435  WinKey timeout
14:00-20.937  WinKey timeout
14:00-21.438  WinKey timeout
...
73 Dominik

Benutzeravatar
DL6ER
Beiträge: 1063
Registriert: Montag 7. März 2011, 21:42
Wohnort: Erftstadt nr Cologne
Kontaktdaten:

Re: DL6ER-Keyer

Beitrag von DL6ER » Samstag 24. Januar 2015, 15:55

Hallo Ben,

mit Beta 10 geht es auch beim COM-Wechsel. Danke.

73 Dominik

Benutzeravatar
DL7UCX
Beiträge: 5053
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: DL6ER-Keyer

Beitrag von DL7UCX » Samstag 24. Januar 2015, 15:58

Hallo Dominik,

beim zweiten Mal war UcxLog der Meinung, daß die Portdaten schon aktuell gesendet wurden, habe das in Beta 10 korrigiert.
Das fehlende PinConfig liegt daran, daß es nur beim Programmstart zusätzlich angestoßen wird. Ist ja aber bereits in dem 0F-Kommando enthalten.

73 Ben

Du bist zu schnell :shock:

Benutzeravatar
DL6ER
Beiträge: 1063
Registriert: Montag 7. März 2011, 21:42
Wohnort: Erftstadt nr Cologne
Kontaktdaten:

Re: DL6ER-Keyer

Beitrag von DL6ER » Mittwoch 17. Juni 2015, 11:44

Hallo Ben,

die aktuelle Beta Version verkündet
CW
- Speed setting refined
Ich konnte aber auf den ersten Blick nichts finden. Muss ich etwas überprüfen, oder bleibt die Änderung für meinen Keyer in jedem Fall folgenlos?

73 Dominik

dl8dww
Beiträge: 535
Registriert: Mittwoch 1. August 2007, 21:14

Re: DL6ER-Keyer

Beitrag von dl8dww » Mittwoch 17. Juni 2015, 13:47

Hallo Dominik,
ich kann nichts Nachteiliges für den Keyer feststellen

73 Wolfgang

Benutzeravatar
DL7UCX
Beiträge: 5053
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: DL6ER-Keyer

Beitrag von DL7UCX » Mittwoch 17. Juni 2015, 19:32

Hallo,

es gibt zwei Kleinigkeiten, die auf WinKey kaum Einfluß haben sollten:

- Die Tempi 125 und 135 cpm sind dazwischen geschoben (= 25 und 27 wpm für WinKey).
- Die Stufung der Punktzeiten bei der UcxLog-internen CW-Erzeugung ist von 2ms auf 1ms verringert worden.

73 Ben

Benutzeravatar
DL6ER
Beiträge: 1063
Registriert: Montag 7. März 2011, 21:42
Wohnort: Erftstadt nr Cologne
Kontaktdaten:

Re: DL6ER-Keyer

Beitrag von DL6ER » Mittwoch 17. Juni 2015, 19:38

Hallo,

In Ordnung - Punkt 1 sollte ohne Bedenken funktionieren und Punkt 2 hat keinen Einfluss. Danke.

73 Dominik

Benutzeravatar
DL6ER
Beiträge: 1063
Registriert: Montag 7. März 2011, 21:42
Wohnort: Erftstadt nr Cologne
Kontaktdaten:

Re: DL6ER-Keyer

Beitrag von DL6ER » Mittwoch 12. August 2015, 14:02

Hallo Ben,
(bitte erst nach Deinem Urlaub beantworten :wink: )

mir ist jetzt schon mehrfach folgendes Verhalten aufgefallen:

Nach einiger Zeit kann ich über CW Send keine Zeichen mehr an den Keyer geben. Es passiert folgendes:
Eingegebener Text / Buchstaben verschwinden sofort (also nicht stückchenweise) ohne über die serielle Schnittstelle gesendet zu werden (in SYSLOG.TXT verfolgt). Der Keyer funktioniert aber selbst einwandfrei. Ich habe mich immer am Kopf gekratzt und UcxLog neugestartet, dann ging es wieder.

Gestern habe ich eine andere Möglichkeit gefunden: Wenn ich in diesem Zustand auf "Tune" klicke, wird dieser Befehl über die serielle Schnittstelle übertragen und der Keyer geht auf Dauerstrich. Deaktiviere ich nun "Tune" wieder, kann ich ganz normal weiterarbeiten, so als wäre nie etwas gewesen.

Hast Du eine Idee woran das liegen könnte? Ich würde den Fehler nicht unbedingt bei meinem Keyer suchen, da wie gesagt überhaupt erst keine Zeichen an den Keyer gesendet werden, die dieser geben könnte. Andererseits könnte es natürlich sein, dass ich irgendwann einmal eine Rückantwort gebe, die UcxLog in eine Sackgasse manövriert :?:

73 Dominik

dl8dww
Beiträge: 535
Registriert: Mittwoch 1. August 2007, 21:14

Re: DL6ER-Keyer

Beitrag von dl8dww » Mittwoch 12. August 2015, 21:33

Hallo Dominik,

mit dem Einsatz beim WAE hat der Keyer den Test sehr gut bestanden.
Verbindungsausfälle traten nicht auf. Auch das von Dir beschriebenen Verhalten ist nicht aufgetreten.
Mit dem automatischen Leerzeichen zwischen Wörtern dürfe es wohl nicht in Zusammenhang stehen ?

Im Zusammenspiel mit UCXLog (7.52 Beta 5) ist kein Unterschied zum Winkey2 festzustellen.
Sehr angenehm sind die Einstellmöglichkeiten der Vor- und Nachlaufzeiten für PTT

HW-seitig ist dieser Keyer mit dem Atmega 328 aufgebaut, der USB-Wandler ein FT232 RL von FTDI.

73 Wolfgang

Benutzeravatar
DL6ER
Beiträge: 1063
Registriert: Montag 7. März 2011, 21:42
Wohnort: Erftstadt nr Cologne
Kontaktdaten:

Re: DL6ER-Keyer

Beitrag von DL6ER » Samstag 15. August 2015, 12:29

Hallo Wolfgang,

vielen Dank für den Test.

Bei meinem Problem handelt es sich durch den mir jetzt bekannten "Trick" nur noch um ein 1/2-Problemchen, da habe ich Zeit es zu lösen. Wenn es bei anderen nicht auftritt, beruhigt es mich schon etwas. Was mich eben nur beunruhigt ist, dass UcxLog scheinbar gar nicht mehr versucht die Zeichen zu übertragen, obwohl es es durchaus könnte (der Tune-Befehl geht ja durch). Da warte ich noch bis Ben wieder da ist und Zeit hat. Ich bin auch selbst gerade auf einer Dienstreise und kann nichts testen / weitere Infos sammeln.

Es freut mich auch zu hören, dass es mit anderen Hardwarekomfigurationen gut funktioniert. Ich hatte es zwar so entworfen, dass es auf gut einem halben Dutzend unterscheidlichen Mikrocontrollern läuft, konnte das mangels Ausrüstung für ATMEL aber nicht selbst testen.

73 Dominik

Benutzeravatar
DL7UCX
Beiträge: 5053
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: DL6ER-Keyer

Beitrag von DL7UCX » Sonntag 16. August 2015, 09:33

Hallo Dominik,

schick mir doch bitte die SYSLOG.TXT, wenn das Problem aufgetreten war.

73 Ben

Antworten