CAT-Probleme

Moderator: DL7UCX

Antworten
Benutzeravatar
DL9GTB
Beiträge: 268
Registriert: Samstag 28. Mai 2011, 20:15
Wohnort: Nossendorf
Kontaktdaten:

CAT-Probleme

Beitrag von DL9GTB »

Hallo Ben,

ich habe seit längerer Zeit ein Problem mit CAT und habe meine momentan vorhandene freie Zeit zu Hause dafür genutzt, der Sache auf den Grund zu gehen. In Verbindung mit meinem FT-2000, Microkeyer II und UcxLog gibt es an für sich kein Problem. Da ich aber seit längerer Zeit mehrere Programme parallel nutze war ich gezwungen einen Serial Port Splitter (Fabulatech) zu nutzen. Zu diesen weiteren Programmen zählt z.B. PstRotator, Tuner Control (Steuerung Christian Koppler), manchmal zusätzliche Decoder (CW-Skimmer) usw., also für mich wichtige und erforderliche Software. Damit kommt UcxLog aber überhaupt nicht zurecht. Ständig wird die Frequenzanzeige gelb, dann wieder nicht, dann wieder ja usw. Es wechselt oft hin und her, die meiste Zeit ist die Anzeige aber gelb und somit nicht aktuell. Nun habe ich ausgiebig alle möglichen Programmvariationen und Einstellungen getestet, aber keine Chance mit UcxLog. Das seltsame an der Sache ist, keines der weiteren getesteten Programme hatte Probleme (Logger32, Log4OM, HRD, Ham Office usw), UcxLog fällt hier leider komplett aus den Rahmen. Das soll keine Kritik sein, aber es ist ärgerlich weil ich mit UcxLog schon fast 20 Jahre arbeite und es natürlich auch weiterhin nutzen möchte.

Ben, hast du evtl. eine Idee woran es liegen könnte? Eine Lösung wäre sicher die Anbindung an OmniRig, aber ich vermute das ist für dich keine Option. Ich würde mich sehr über deine Hilfe freuen.

Noch etwas. Testweise habe ich als TRX mal den FT-5000 eingestellt, Das funktionierte zwar nicht aber es erschien ein grünes A vor der Frequenzanzeige, sowie ein B mit der entsprechenden Differenz zum VFO A. Das finde ich richtig gut, ist das evtl. auch für andere Transceiver wie den FT-2000 möglich?

73 de Torsten - DL9GTB
Benutzeravatar
DL7UCX
Beiträge: 5804
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: CAT-Probleme

Beitrag von DL7UCX »

Hallo Torsten,

wenn "UcxLog damit nicht zurecht kommt", liegt das an gestörten seriellen Daten, mehr "sieht" UcxLog ja nicht.
Das kann dann eigentlich nur am COM-Port-Treiber liegen, verbreitet tritt das in Abhängigkeit vom dem Port-Modus (Blockierend oder Überlappend) auf.

Für diese Probleme gibt es den Umschalter "Simple COM Port IO method" in "Settings-Station-Special".
Welche Einstellung besser ist, läßt sich leider nicht vorhersagen ...

OmniRig werde ich nicht verwenden, ich werde mich mit UcxLog ohne Not nicht in solch eine Abhängigkeit begeben.

Die aufwendigere Anzeige beim FT-5000 hatte ich mir "gegönnt", weil ich den einige Jahre selber hatte.
Das will/kann ich aus Aufwandsgründen nicht auf andere TRX erweitern.

73 Ben
Benutzeravatar
DL9GTB
Beiträge: 268
Registriert: Samstag 28. Mai 2011, 20:15
Wohnort: Nossendorf
Kontaktdaten:

Re: CAT-Probleme

Beitrag von DL9GTB »

Hallo Ben,

ich habe die "Simple COM Port IO method" aktiviert und nun scheint es zu funktionieren. Ich hoffe das es dabei bleibt. Vielen Dank für den Hinweis und deine Hilfe. Allein wäre ich nie darauf gekommen. Als Gute und bleibt gesund.

73 de Torsten - DL9GTB
Benutzeravatar
DL7UCX
Beiträge: 5804
Registriert: Donnerstag 8. August 2002, 19:23
Wohnort: Dabendorf
Kontaktdaten:

Re: CAT-Probleme

Beitrag von DL7UCX »

Anscheinend verwenden andere Logprogramme (immer?) die "Simple COM Port IO method".
Bei der CW-Tastung über DTR/RTS kann das aber auch zu unsauberen Zeichen führen.

Im Endeffekt sind das Programmierfehler im Treiber oder auch in Windows, sonst müsste immer beides funktionieren.

73 Ben
Antworten