Zugriffsverletzung beim Lesen

Moderator: DL7UCX

Benutzeravatar
DL7UCX
Beiträge: 422
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: Zugriffsverletzung beim Lesen

Beitragvon DL7UCX » 11. April 2013, 11:54

Hallo,

bei mir ist dieser Fehler noch nie aufgetreten, wobei seit einigen Jahren fast nur noch Windows7 64bit läuft.
Ich könnte das nur einkreisen, wenn UcxLog unter meiner Entwicklungsumgebung (mit Debugger) läuft und dann der Fehler auftritt.

Die Frage wäre noch, ob es in allen Fehlerfällen etwas gemeinsames in der Konfiguration gibt (Ports, Treiber, Internet, RTTY).
Wenn es auch ohne Bedienereingaben auftritt, müßte es von außen getriggert werden (DX-Cluster, Ports, Soundkarte/MMTTY).

73 Ben

Benutzeravatar
DL6ER
Beiträge: 32
Registriert: 7. März 2011, 20:42
Wohnort: Erftstadt nr Cologne
Kontaktdaten:

Re: Zugriffsverletzung beim Lesen

Beitragvon DL6ER » 11. April 2013, 13:14

Hallo Ben,

kurzer Nachtrag: Bei mir ist es immer (wobei das wirklich selten war) während des Starts aufgetreten (direkt am Anfang, als sich die Fenster noch aufgebaut haben), hat aber auch keine Beeinträchtigung für den Betrieb ergeben.

73 Dominik

Benutzeravatar
DL7UCX
Beiträge: 422
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: Zugriffsverletzung beim Lesen

Beitragvon DL7UCX » 11. April 2013, 13:21

Hallo Dominik,

damit ist es aber anscheinend etwas anderes als bei Gerd.
Wie lange ist der letzte Error denn her?

73 Ben

Benutzeravatar
DL6ER
Beiträge: 32
Registriert: 7. März 2011, 20:42
Wohnort: Erftstadt nr Cologne
Kontaktdaten:

Re: Zugriffsverletzung beim Lesen

Beitragvon DL6ER » 11. April 2013, 15:16

Hallo Ben,

das ist wirklich schwer abzuschätzen...auf jeden Fall schon länger...würde auf Januar diesen Jahres tippen, meine Funkaktivität hat aber auch (wegen Schreiben der Abschlussarbeit) drastisch (!) abgenommen.

73 Dominik

DJ4KW
Beiträge: 2
Registriert: 15. Januar 2007, 14:16
Wohnort: 21337 Lüneburg
Kontaktdaten:

"Zugriffsverletzung beim Lesen" WORK-Fenster NAME-Feld

Beitragvon DJ4KW » 17. April 2013, 07:53

Hallo Ben, hallo Dominik,

Betriebssystem hier ist Windows XP Professional, auf Mac Book unter Parallels Desktop und Mac OS 10.6.8. Der Fehler ist nicht reproduzierbar und tritt einfach viel zu selten auf. Heute Nacht hatte ich die Situation, dass ich die Zugriffsverletzung zum ersten Mal mehrmals wiederholt provozieren konnte. Ich war im WORK-Fenster, Frequenz und Betriebsart waren schon automatisch übernommen nachdem ich das Rufzeichen meiner Gegenstation ins Feld CALL SIGN eingetragen habe. Der voreingestellte Rapport 599 passte. Die Gegenstation gab ihren Namen durch und ich ging also wie immer gleich mit der Maus auf das Feld NAME. Dann trat reproduzierbar jedes mal die Zugriffsverletzung auf, wenn ich das Feld mit Hilfe der Maus betreten wollte; es half nur stattdessen die Tabulator-Taste zu nehmen. Nicht spektakulär genug, um in "The Journal of Irreproducible Results" publiziert zu werden, aber es könnte mit der Navigation, speziell mit dem NAME-Feld zu tun haben.
73
Gerd DJ4KW

Benutzeravatar
DL7UCX
Beiträge: 422
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: Zugriffsverletzung beim Lesen

Beitragvon DL7UCX » 17. April 2013, 10:16

Hallo Gerd,

die Editor-Komponente für den Namen empfängt (bearbeitet) spezifisch nur 2 Events, OnChange und OnKeyDown, keinerlei Maus-bezogene Events. Lediglich die rechte Maustaste öffnet automatisch das zugeordnete PopUp-Menü.
Auch die übergeordnete Form verarbeitet explizit kein Maus-Event.
Das heißt, alle Maus-Aktionen werden auf der Position des Namens-Feldes ausschließlich von Delphi/Windows verarbeitet.

Ich würde die Fehlerfreiheit eines virtualisierten Betriebssystems :roll: noch deutlich skeptischer sehen als sowieso schon.

73 Ben

dl8dww
Beiträge: 26
Registriert: 1. August 2007, 19:14

Re: Zugriffsverletzung beim Lesen

Beitragvon dl8dww » 19. August 2013, 08:45

Fehler_a.gif
Fehler_a.gif (81.73 KiB) 1565 mal betrachtet
Hallo Ben,
Zugriffsverletzungen treten auch bei mir beim vereinzelt auf. Allerdings nur beim Programmupdate und auch beim Rückfall auf die vorherige Version.
Nach Bestätigen der Meldung gehts ohne Probleme weiter.
73 Wolfgang
Dateianhänge
Fehler.gif
Fehler.gif (84.42 KiB) 1565 mal betrachtet

DL6AU
Beiträge: 0
Registriert: 9. Mai 2013, 18:00
Wohnort: Friedberg (Hessen)

Re: Zugriffsverletzung beim Lesen

Beitragvon DL6AU » 19. August 2013, 12:01

Hallo,

ich kann mich erinnern, dass es bei unseren XP-Rechnern immer wieder Probleme gab, wenn private Software installiert wurde. Häufig kam es durch unsauber programmierte Treiber dazu, dass ganz andere Programme, die mit diesen Treiber gar nichts zu tun hatten, nicht nachvollziehbare Fehler produzierten. In Einzelfällen half nur noch komplette Neuinstallation. :evil:
Vielleicht ist es hier etwas ähnliches.
73 Uwe

Benutzeravatar
DL7UCX
Beiträge: 422
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: Zugriffsverletzung beim Lesen

Beitragvon DL7UCX » 19. August 2013, 12:19

Hallo,

ich habe den subjektiven Eindruck, daß es nur auf XP-Rechnern vereinzelt zu diesen Problemen beim Programm-Beenden kommt.

73 ben

dl3kvr
Beiträge: 88
Registriert: 18. November 2009, 09:55

Re: Zugriffsverletzung beim Lesen

Beitragvon dl3kvr » 19. August 2013, 18:36

Nein Ben,
auch bei Win 7, aber relativ selten.
Da ein Ignorieren keine Folgen hatte, war es mir bisher Wurscht.
Früher mit XP und 10 Jahre altem Rechner trat der Effekt regelmäßig auf.
73 Diet


Zurück zu „Betriebssysteme“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast