Hohe Systemauslastung beim Betrieb von UcxLog

Moderator: DL7UCX

DF9OB
Beiträge: 10
Registriert: 16. August 2011, 19:17

Hohe Systemauslastung beim Betrieb von UcxLog

Beitragvon DF9OB » 8. September 2015, 18:17

Hallo,

seit einiger Zeit fällt mir auf, dass UcxLog (V 7.51) ca. 25 % der CPU meines Notebooks in Anspruch nimmt, Bei dem Notebook handelt es sich um LENOVO ThinkPad S430 mit einen Intel Core I5 Prozessor und 8 GB Speicher, Betriebssystem ist Windows 7 Home Premium (64 Bit).

Angeschlossen sind mein YAESU FT-950 und mein FT-991.

Vielleicht hat ja jemand eine Idee oder vergleichbares beobachtet.

Würde mich über Anregungen, Hilfe usw. freuen.

Gruß
Bernd / DF9OB

Gruß Bernd/df9ob
  df9ob (at) web (.) de
+49 152 51920138

DL1EZ
Beiträge: 340
Registriert: 16. November 2008, 10:49

Re: Hohe Systemauslastung beim Betrieb von UcxLog

Beitragvon DL1EZ » 8. September 2015, 19:09

Hallo Bernd,

kann ich nicht bestätigen, UCXLog dümpelt hier so zwischen 0 und 1 (wenn überhaupt) Prozent CPU Last rum mit 1 angeschlossenen TRX und Microham Microkeyer, 2 Cluster über telnet)

Gruß, Holger

PS:
Vielleicht solltest Du Deine Kontaktdaten aus der Signatur nehmen, das wird sonst nur leichte Beute für Harvester..

Benutzeravatar
DL7UCX
Beiträge: 5016
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: Hohe Systemauslastung beim Betrieb von UcxLog

Beitragvon DL7UCX » 8. September 2015, 19:27

Hallo Bernd,

ich habe nicht gehört, daß irgendwo eine hohe Systemlast aufgetreten wäre.
Ich habe auch keine Erklärung dafür.
Bei Problemen aller Art hat es in letzter Zeit oft geholfen, den Virenscanner temporär lahmzulegen.

Du könntest auch ein Update auf die 7.52 Beta machen, das wird zumindest nichts schaden.

73 Ben

dl8dww
Beiträge: 535
Registriert: 1. August 2007, 19:14

Re: Hohe Systemauslastung beim Betrieb von UcxLog

Beitragvon dl8dww » 9. September 2015, 08:53

Hallo Bernd,mir war ähnliches passiert, da ging eine Zeitlang nichts mehr.
Ursache war,daß die Kiste am updaten von Win7 war.
73 Wolfgang

DL1EZ
Beiträge: 340
Registriert: 16. November 2008, 10:49

Re: Hohe Systemauslastung beim Betrieb von UcxLog

Beitragvon DL1EZ » 9. September 2015, 12:09

Ja, stimmt, könnte von der Zeit her Patchday gewesen sein..

Benutzeravatar
DL6ER
Beiträge: 1060
Registriert: 7. März 2011, 20:42
Wohnort: Erftstadt nr Cologne
Kontaktdaten:

Re: Hohe Systemauslastung beim Betrieb von UcxLog

Beitragvon DL6ER » 9. September 2015, 12:18

Nur so am Rande...

http://www.gulli.com/news/26452-microso ... 2015-08-26
Es handelt sich hierbei um eine seit vielen Jahren betriebene Internetredaktion deren Glaubwürdigkeit also sehr hoch einzuschätzen ist.

73 Dominik

DF9OB
Beiträge: 10
Registriert: 16. August 2011, 19:17

... eigene Anmerku Hohe Systemauslastung beim Betrieb von Uc

Beitragvon DF9OB » 9. September 2015, 16:42

Hallo an Alle,

danke für die bisherigen Beiträge. Leider hat nichts von den Ideen und Hinweisen geholfen. :( UcxLog parkt hartnäckig bei einer CPU-Auslastung von 25%. Dies würde mich normalerweise nicht stören, wenn der Lüfter meines Notebooks nicht permanent laufen würde. Dies macht er nun mal bei 25% permanent. Übrigens; auch wenn keine Updates anstehen.

@Ben; Was und wo könnte ich noch nachsehen?
Virenscanner und Firewall habe ich zum Test abgeschaltet (ohne Erfolg/Besserung). Schnittstellen und Telnet deaktiviert (auch keine Besserung).
Gibt es irgend eine Möglichkeit zur Erstellung von Diagnoseunterlagen? Was könnte ich Dir liefern?

Danke @all
Bernd / DF9OB

Benutzeravatar
DL7UCX
Beiträge: 5016
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: Hohe Systemauslastung beim Betrieb von UcxLog

Beitragvon DL7UCX » 9. September 2015, 18:11

Hallo Bernd,

UcxLog kann die eigene Systemlast nicht erkennen, da gibt es also nichts zu diagnostizieren.

Was zeigt der Taskmanager? Ist eine CPU auf Volllast?

Du könntest mal mit "Help - Install other log" ein zweites, neues Log installieren, z.B. für SP/DF9OB.
Dann dieses starten, minimal einrichten und sehen, ob die Last auch so ist.

73 Ben

DL1DTL
Beiträge: 729
Registriert: 12. September 2002, 07:44
Wohnort: Dresden

Re: Hohe Systemauslastung beim Betrieb von UcxLog

Beitragvon DL1DTL » 10. September 2015, 13:00

Hallo,

habe mal meinen Laptop getestet. Die CPU-Last ist nur im Moment des Startens von UCXLog hoch, danach verschwindend gering.

@Bernd, kommt die Belastung wirklich von UCXLog oder werkelt da noch was anderes im Untergrund?

73 Klaus

Benutzeravatar
DL6ER
Beiträge: 1060
Registriert: 7. März 2011, 20:42
Wohnort: Erftstadt nr Cologne
Kontaktdaten:

Re: Hohe Systemauslastung beim Betrieb von UcxLog

Beitragvon DL6ER » 11. September 2015, 14:00

DL1DTL hat geschrieben:Die CPU-Last ist nur im Moment des Startens von UCXLog hoch, danach verschwindend gering.

Beim Starten werden die diversen Liste eingelesen, die UcxLog verwendet, da ist 100% Arbeit angesagt. Im laufenden Betrieb stehen die Daten dann im Speicher zur Verfügung und machen selbst keine Arbeit mehr. Das kann man "verschlimmern" wenn man bspw. die W-Liste installiert. Entsprechend der 3/4 Million Einträge, ist dann noch deutlich mehr Arbeit zum Start angesagt. Aber auch hier gilt, dass hieraus kein bemerkbarer Nachteil entstehen sollte (angenommen der Speicher ist groß genug um die Menge an Daten zu fassen).

Ich beobachte auch keine sonderliche Auslastung auf meinem Windows Laptop. Kann man unter Windows sehen wieviel Leistung die individuellen Threads verbrauchen und ob nur einer oder alle viel Leistung ziehen?

Auch in Nicht-Windows Umgebung verbraucht UcxLog nach dem Start konstant weniger als 1%:
Bild

73 Dominik

DL1DTL
Beiträge: 729
Registriert: 12. September 2002, 07:44
Wohnort: Dresden

Re: Hohe Systemauslastung beim Betrieb von UcxLog

Beitragvon DL1DTL » 11. September 2015, 15:16

Hi Domonik,

DL6ER hat geschrieben:...

Ich beobachte auch keine sonderliche Auslastung auf meinem Windows Laptop. Kann man unter Windows sehen wieviel Leistung die individuellen Threads verbrauchen und ob nur einer oder alle viel Leistung ziehen?
....

73 Dominik




die Angaben für den einzelnen Thread habe ich noch nicht gefunden - wenn das mit Bordmitteln überhaupt geht - aber wenn ich das Angezeigte richtig interpretiere, sind es beim Starten von UCXLog.exe maximal 50% für einen kurzen Moment.
Ich denke, Ben kann das besser erklären.

73 Klaus

Benutzeravatar
DL7UCX
Beiträge: 5016
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: Hohe Systemauslastung beim Betrieb von UcxLog

Beitragvon DL7UCX » 11. September 2015, 16:30

Hallo,

eine Möglichkeit, die CPU-Last jedes Threads zu sehen, habe ich mit Windows-Bordmitteln nicht gefunden.

Bernd hat inzwischen durch schrittweises Hinzufügen der Interfaces ergründet, daß die Last von einem USB-COM-Adapter (für TRX) kommt.
Habe ihm geraten, einen anderen Konverter (nicht mit Profilic sondern FTDI) zu kaufen.

73 Ben

DF9OB
Beiträge: 10
Registriert: 16. August 2011, 19:17

. . . . Problem gelöst … Hohe Systemauslastung beim Betrieb

Beitragvon DF9OB » 20. September 2015, 09:57

Hallo an Alle,

danke für die interessanten Beiträge. ;) Nach intensiven Tests und Hinweisen von Ben (vielen dank dafür) ist das Problem gelöst.

Meine Beobachtungen und die daraus resultierende Lösung sieht wie folgt aus:

1. Testserie:
- Nach der Installation eines neuen Logbuchs (Help → Install other Log) und dem erneuten Start (minimal Konfiguration) liegt die Auslastung im
normalen Bereich (so bei <5% nur UcxLog). Also alles in Ordnung.
- Nach der Einstellung/„Bekanntgabe“ meines FT-950 (Frequenz und Mode wurden sofort
angezeigt) sofort 25% Auslastung. (nur UcxLog)
- Einstellung Rückgängig, wieder alles in Ordnung.
- Einstellung meines FT-991, (qrg und mode werden angezeigt) weiterhin
alles in Ordnung (CPU so bei <5%). :)

Verwendete Hardware beim Test war:
Prolific USB.Serial Treiber für den FT-950
und
Silicon Labs Dual CP210x USB to UART Bridge für den FT-991

Lösung und Fazit:
Der Empfehlung von Ben folgend habe ich mir einen anderen RS232 to USB Adapter zugelegt und installiert. Ich betreibe jetzt einen DIGITUS DA-70156 mit einem "FTDI" -Chipsatz.
UcxLog benötigt nun mit „angemeldeten“ FT-950 und FT-991 um die 5%. Es ist also alles wieder in Ordnung. :D :D :D


Viele Grüße Bernd

dk4ww
Beiträge: 11
Registriert: 22. Februar 2012, 09:22
Wohnort: EU

Re: Hohe Systemauslastung beim Betrieb von UcxLog

Beitragvon dk4ww » 20. November 2015, 08:55

Guten Morgen,

nach Tausch auf FTDI Adapter ging die Prozessorlast auch bei mir zurück.

73
Uwe

Benutzeravatar
DL7UCX
Beiträge: 5016
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: Hohe Systemauslastung beim Betrieb von UcxLog

Beitragvon DL7UCX » 20. November 2015, 09:02

Danke für die Rückmeldungen :D

73 Ben


Zurück zu „Betriebssysteme“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 2 Gäste