Uhrzeit der versendeten Mails mutmaßlich falsch?

Moderator: DL7UCX

DG9VH
Beiträge: 0
Registriert: 7. Mai 2011, 08:33
Wohnort: Völklingen, JN39KF

Uhrzeit der versendeten Mails mutmaßlich falsch?

Beitragvon DG9VH » 6. April 2013, 15:53

Ich habe heute mal die Mailfunktion konfiguriert und eine Testmail gesendet. Die Testmail wurde erfolgreich verschickt, was mir jedoch auffiel, ist die Tatsache, dass die Uhrzeit der Mail um 2 Stunden "vorläuft", also die Mail von 17:45 Uhr (MESZ) ist im Mailprogramm um 19:45 Uhr angezeigt.

Hier mal die Headerzeilen (anonymisiert):
Return-path: <xxx@xxx-xxx.de>
Envelope-to: xxx@xxx-xxx.de
Delivery-date: Sat, 06 Apr 2013 17:44:52 +0200
Received: from [188.107.x.y] (helo=SANDRA-PC)
by server33.x.y with esmtpa (Exim 4.80)
(envelope-from <xxx@xxx-xxx.de>)
id 1UOVIR-002t2z-Ud
for xxx@xxx-xxx.de; Sat, 06 Apr 2013 17:44:52 +0200
From: "kim@huebel-online.de" <xxx@xxx-xxx.de>
Subject: UcxLog Test Mail
To: xxx@xxx-xxx.de
Content-Type: multipart/mixed
Date: Sat, 6 Apr 2013 17:44:53 +0000


Der Grund liegt in der fett dargestellten Zeile: Hier wird entweder die Uhrzeit falsch eingetragen oder die Zeitzone nicht korrekt gesetzt. Die Uhrzeit die hier aufgeführt wird ist in MESZ, sollte aber bei eingestellter Zeitzone UTC sein. Es ist vermutlich einfacher (da UcxLog intern eh schon die UTC-Zeit ermittelt), diese reinzusetzen anstatt die Zeitzone entsprechend zu ermitteln... da das Programm ja über den ganzen Globus verteilt eingesetzt werden könnte, müsste hier vom Betriebssystem die Zone genommen werden, was sicherlich nicht wirklich einfach und sicher ist.

UTC zu verwenden ist jedoch ein legales Mittel, finde ich...

Ich weiß nicht, ob der Bug auch bei produktiv versendeten Mails drin ist - ich habe es noch nicht ausprobiert...

73, Kim
DG9VH

Benutzeravatar
DL6ER
Beiträge: 32
Registriert: 7. März 2011, 20:42
Wohnort: Erftstadt nr Cologne
Kontaktdaten:

Re: Uhrzeit der versendeten Mails mutmaßlich falsch?

Beitragvon DL6ER » 6. April 2013, 16:14

Kann dieses Verhalten bestätigen. Tritt auch bei Contest-Log-Einsendungen auf (habe ich bisher nur nicht drauf geachtet).

Es ist 18:15 Lokalzeit
UCX-Log sagt 16:15 UTC
Die E-Mail behauptet 20:15 Uhr...

Hmm...

73 Dominik

DG9VH
Beiträge: 0
Registriert: 7. Mai 2011, 08:33
Wohnort: Völklingen, JN39KF

Re: Uhrzeit der versendeten Mails mutmaßlich falsch?

Beitragvon DG9VH » 6. April 2013, 16:17

Ließe sich wie gesagt dadurch beheben, indem statt der Local-Time die UTC in die Mail reingenommen wird :-)

Benutzeravatar
DL6ER
Beiträge: 32
Registriert: 7. März 2011, 20:42
Wohnort: Erftstadt nr Cologne
Kontaktdaten:

Re: Uhrzeit der versendeten Mails mutmaßlich falsch?

Beitragvon DL6ER » 6. April 2013, 16:21

DG9VH hat geschrieben:Ließe sich wie gesagt dadurch beheben, indem statt der Local-Time die UTC in die Mail reingenommen wird :-)

Naja, es gibt ja auch zur Local-Time eine Differenz, also wird aktuell entweder Local-Time + 2h oder UTC + 4h (was ich eher für unwahrscheinlich halte) benutzt.

DG9VH
Beiträge: 0
Registriert: 7. Mai 2011, 08:33
Wohnort: Völklingen, JN39KF

Re: Uhrzeit der versendeten Mails mutmaßlich falsch?

Beitragvon DG9VH » 6. April 2013, 16:48

Ne, schau dir mal die Headerzeilen an. Dann siehst du, dass es ausreichen würde in der fett gedruckten Zeile UTC zu nehmen als Zeit... also 15:44 statt 17:44 und es würde passen, weil die Differenz zu UTC ja mit 0000 angegeben wurde. Die anderen Zeiten sind korrekt mit +0200 codiert...

Benutzeravatar
DL6ER
Beiträge: 32
Registriert: 7. März 2011, 20:42
Wohnort: Erftstadt nr Cologne
Kontaktdaten:

Re: Uhrzeit der versendeten Mails mutmaßlich falsch?

Beitragvon DL6ER » 6. April 2013, 16:54

Ja, ich habe mir nur die Auswirkung angesehen, aber keinen genaueren Blick auf die Ursache geworfen. Habe die entsprechenden Zeilen mal als Zitat zusammengekürzt:
DG9VH hat geschrieben:Delivery-date: Sat, 06 Apr 2013 17:44:52 +0200
...
for xxx@xxx-xxx.de; Sat, 06 Apr 2013 17:44:52 +0200
...
Date: Sat, 6 Apr 2013 17:44:53 +0000


Wenn ich das richtig verstehe wäre das korrekte Verhalten 1. alle Uhrzeiten in UTC zu verwenden und 2. unter Date dann noch auf +0200 zu korrigieren, oder wird ein Teil dieses Headers vom empfangenden Server erstellt?
Fragt sich nur, wie sehr sich die Komponente, die Ben dafür benutzt, in die Karten pfuschen lässt :D

73 Dominik

Benutzeravatar
DL7UCX
Beiträge: 420
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: Uhrzeit der versendeten Mails mutmaßlich falsch?

Beitragvon DL7UCX » 6. April 2013, 16:56

STOOOOOP

DG9VH
Beiträge: 0
Registriert: 7. Mai 2011, 08:33
Wohnort: Völklingen, JN39KF

Re: Uhrzeit der versendeten Mails mutmaßlich falsch?

Beitragvon DG9VH » 6. April 2013, 16:59

Also die oberen Zeitangaben stammen vom Server selbst... die sind auch korrekt, der arbeitet lokal aktuell in MESZ, kodiert das entsprechend als Differenz zu UTC mit +0200... bedeutet, um auf UTC zu kommen, muss man von der Uhrzeit 2 Stunden abziehen...

Die unterste Zeile stammt von UCX und ist leider falsch. Die einfachste Lösung wäre hier, die Uhrzeit selbst mit der UTC-Zeit zu füllen statt mit der lokalen Zeit, da die ja immer stabil definiert ist, die lokale Zeit jedoch je nach Zeitzone differiert... ich denke aber, das sollte auch kein Problem sein, da Ben denke ich im UcxLog die Differenz ja schon irgendwo ermittelt (ich musste nämlich glaube ich noch nie die Differenz von Hand angeben irgendwo)...

73, Kim

DG9VH
Beiträge: 0
Registriert: 7. Mai 2011, 08:33
Wohnort: Völklingen, JN39KF

Re: Uhrzeit der versendeten Mails mutmaßlich falsch?

Beitragvon DG9VH » 6. April 2013, 17:00

DL7UCX hat geschrieben:STOOOOOP


Microphone to Ben, we are listening :)

Benutzeravatar
DL7UCX
Beiträge: 420
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: Uhrzeit der versendeten Mails mutmaßlich falsch?

Beitragvon DL7UCX » 6. April 2013, 17:00

Hallo,

vor lauter Posts kommt man ja nicht mehr zum Korrigieren :roll:

Die benutzte INDY-Komponente hat ein Property UseNowForDate, das augenscheinlich nur Unfug macht.
Ich habe das Date-Property in Beta 14 nun selber auf die Windows-Lokalzeit gesetzt, bei mir hat es funktioniert.

73 Ben

DG9VH
Beiträge: 0
Registriert: 7. Mai 2011, 08:33
Wohnort: Völklingen, JN39KF

Re: Uhrzeit der versendeten Mails mutmaßlich falsch?

Beitragvon DG9VH » 6. April 2013, 17:08

Hm.. bei dir bedeutet nicht bei allen... ich habe jetzt die BETA14 installiert und bekomme 1:1 den gleichen "Fehler":

Date: Sat, 6 Apr 2013 19:05:50 +0000

Die Differenz wird nicht gesetzt... es wäre für dich glaube ich wirklich einfacher und stabiler, du würdest statt der lokalen Zeit die UTC-Zeit reinhauen, die du ja eh schon fürs Logging ermittelst irgendwo... :-) Dann brauchst dich nicht drum kümmern, was Windows dir liefert...

Kim

Benutzeravatar
DL6ER
Beiträge: 32
Registriert: 7. März 2011, 20:42
Wohnort: Erftstadt nr Cologne
Kontaktdaten:

Re: Uhrzeit der versendeten Mails mutmaßlich falsch?

Beitragvon DL6ER » 6. April 2013, 17:08

Bei mir leider nicht, füge auch wie Kim eben den Header ein:

Code: Alles auswählen

Delivered-To: xxx@gmail.com
Received: by 10.68.31.164 with SMTP id b4csp217747pbi;
        Sat, 6 Apr 2013 10:05:17 -0700 (PDT)
X-Received: by 10.194.104.168 with SMTP id gf8mr22694879wjb.58.1365267917156;
        Sat, 06 Apr 2013 10:05:17 -0700 (PDT)
Return-Path: <xxx@uni-koeln.de>
Received: from smtp-out.rrz.uni-koeln.de (smtp-out.rrz.uni-koeln.de. [134.95.19.53])
        by mx.google.com with ESMTPS id fo3si2554693wib.99.2013.04.06.10.05.16
        (version=TLSv1 cipher=RC4-SHA bits=128/128);
        Sat, 06 Apr 2013 10:05:17 -0700 (PDT)
Received-SPF: pass (google.com: domain of xxx@uni-koeln.de designates 134.95.19.53 as permitted sender) client-ip=134.95.19.53;
Authentication-Results: mx.google.com;
       spf=pass (google.com: domain of xxx@uni-koeln.de designates 134.95.19.53 as permitted sender) smtp.mail=xxx@uni-koeln.de
X-Virus-Scanned: amavisd-new at uni-koeln.de
Received: from smtp.uni-koeln.de (milter4.rrz.uni-koeln.de [134.95.19.193])
   by smtp-out.rrz.uni-koeln.de (8.13.8/8.13.8) with ESMTP id r36H5FZX004955
   for <xxx@googlemail.com>; Sat, 6 Apr 2013 19:05:16 +0200
Received: from clotho.rrz.uni-koeln.de (clotho.rrz.uni-koeln.de [134.95.19.20])
   by smtp.uni-koeln.de (8.13.8/8.13.8) with ESMTP id r36H5FZP031235
   for <xxx@googlemail.com>; Sat, 6 Apr 2013 19:05:15 +0200
Received: from clotho.rrz.uni-koeln.de (localhost.localdomain [127.0.0.1])
   by clotho.rrz.uni-koeln.de (8.13.8/8.13.8) with ESMTP id r36H5FhN026111
   for <xxx@googlemail.com>; Sat, 6 Apr 2013 19:05:15 +0200
Received: (from cyrus@localhost)
   by clotho.rrz.uni-koeln.de (8.13.8/8.13.8/Submit) id r36H5F4S026110
   for xxx@googlemail.com; Sat, 6 Apr 2013 19:05:15 +0200
Received: from smtp-in.rrz.uni-koeln.de ([unix socket])
    by cyrus.rrz.uni-koeln.de (Cyrus v2.4.17-Invoca-RPM-2.4.17-6.RRZK) with LMTPA;
    Sat, 06 Apr 2013 19:05:15 +0200
X-Sieve: CMU Sieve 2.4
Received: from seraph.rrz.uni-koeln.de (seraph.rrz.uni-koeln.de [134.95.19.134])
   by smtp-in.rrz.uni-koeln.de (8.13.8/8.13.8) with ESMTP id r36H5F0i026107
   for <xxx@uni-koeln.de>; Sat, 6 Apr 2013 19:05:15 +0200
X-IronPort-AV: E=Sophos;i="4.87,421,1363129200";
   d="scan'208";a="5515124"
X-Marked-By: $TRUSTED
Received: from smtp-out.rrz.uni-koeln.de ([134.95.19.53])
  by seraph.rrz.uni-koeln.de with ESMTP; 06 Apr 2013 19:05:16 +0200
X-Virus-Scanned: amavisd-new at uni-koeln.de
Received: from smtp.uni-koeln.de (milter2.rrz.uni-koeln.de [134.95.19.191])
   by smtp-out.rrz.uni-koeln.de (8.13.8/8.13.8) with ESMTP id r36H5FkQ004952
   for <xxx@uni-koeln.de>; Sat, 6 Apr 2013 19:05:15 +0200
X-MSA-SIP: vpn83-2.vpn.uni-koeln.de [134.95.83.2]
Received: from dderigs-server (vpn83-2.vpn.uni-koeln.de [134.95.83.2])
   by smtp.uni-koeln.de (8.13.8/8.13.8) with ESMTP id r36H5EKQ020674
   for <xxx@uni-koeln.de>; Sat, 6 Apr 2013 19:05:14 +0200
Message-Id: <201304061705.r36H5EKQ020674@smtp.uni-koeln.de>
From: "xxx@uni-koeln.de" <xxx@uni-koeln.de>
Subject: UcxLog Test Mail
To: xxx@uni-koeln.de
Content-Type: multipart/mixed
Date: Sat, 6 Apr 2013 19:05:14 +0000
X-Scanned-By: MIMEDefang 2.73
X-Scanned-By: MIMEDefang 2.73

Mail sent by UcxLog via SMTP.

-------


Zusammengefasst: Mit Beta 14 unverändert.

Benutzeravatar
DL7UCX
Beiträge: 420
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: Uhrzeit der versendeten Mails mutmaßlich falsch?

Beitragvon DL7UCX » 6. April 2013, 17:12

Die Komponente hat nur ein Feld für den Datumswert (mit Uhrzeit), das ist eine Gleitkommazahl.
Keine Zeitzone.
Das wird bei mir genauso in die gesendete Mail reingeschrieben.

Ist denn Eure Windows-Lokalzeit richtig?

73 Ben

Benutzeravatar
DL6ER
Beiträge: 32
Registriert: 7. März 2011, 20:42
Wohnort: Erftstadt nr Cologne
Kontaktdaten:

Re: Uhrzeit der versendeten Mails mutmaßlich falsch?

Beitragvon DL6ER » 6. April 2013, 17:14

DL7UCX hat geschrieben:Ist denn Eure Windows-Lokalzeit richtig?

Um ehrlich zu sein, bin ich mir jetzt nicht sicher, wie ich das ermitteln soll.

Jedenfalls kann ich sagen, dass meine "Uhr" korrekt 19:14 Uhr anzeigt und UCXLog auch die korrekte UTC kennt (also auch die Zeitzone stimmen sollte).

DG9VH
Beiträge: 0
Registriert: 7. Mai 2011, 08:33
Wohnort: Völklingen, JN39KF

Re: Uhrzeit der versendeten Mails mutmaßlich falsch?

Beitragvon DG9VH » 6. April 2013, 17:15

Würde sagen, ja...
Dateianhänge
Uhr.JPG
Uhr.JPG (36.09 KiB) 1320 mal betrachtet


Zurück zu „Netze“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast