PSK Decodes in RX but no TX

Moderator: DL7UCX

M0KCM
Beiträge: 4
Registriert: 21. Juli 2013, 20:18

PSK Decodes in RX but no TX

Beitragvon M0KCM » 22. Juli 2013, 07:42

Hi guys
Firstly apologies this message is in English. I hope it doesn't cause too many problems....

OK, I've been trying to get the PSK mode working on UCXlog, but so far I've not been successful. Firstly, I am happy to say that RTTY mode using the MMTTY engine works superb. DXCC worked in just 33 days so for me, it's perfect. (It also tells me that the connection between my laptop and radio are good :D )
So, I select psk mode in the logbook and the psk window opens. Immediately I can decode signals from all over Europe so PSK RX is fine. When I tried to transmit, I use the same macro's that I have for RTTY (F1 - F11 in the decode window). My computer screen shows the text I'm trying to send in the decode window. The waterfall changes to show transmission instead of receive pattern. Everything looks as I would expect it to, only the radio is firmly in RX mode.
emachines netbook windows 7. G4ZLP minipro usb interface, kenwood TS570.

Any ideas what I'm missing?

thanks in advance - Ian M0KCM

Benutzeravatar
DL7UCX
Beiträge: 5016
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: PSK Decodes in RX but no TX

Beitragvon DL7UCX » 22. Juli 2013, 15:09

Hello Ian,

Did you activate "PTT" in "Settings-Station-Transceivers"?
It is possible using Port / PTT line or via CAT.

Do you work with MMTTY in AFSK or FSK ?
If you use FSK then check for PSK the audio connection from soundcard output to TRX audio input.

See also "Help - FAQs".

73 Ben

M0KCM
Beiträge: 4
Registriert: 21. Juli 2013, 20:18

Re: PSK Decodes in RX but no TX

Beitragvon M0KCM » 23. Juli 2013, 12:30

Hi Ben

Ticking the 'PTT' box does make the radio switch into transmit at the appropriate times, but no tones are reaching the radio, so I'm guessing the levels must be very different to the RTTY settings.
I use MMTTY through AFSK as my interface doesn't allow for FSK operation.

With the iota contest coming in just a couple of days, I will wait until afterwards before I make any more investigations. Thanks Ben

Ian - M0KCM

Benutzeravatar
DL7UCX
Beiträge: 5016
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: PSK Decodes in RX but no TX

Beitragvon DL7UCX » 23. Juli 2013, 17:32

Hi Ian,

You have to set the right level using the windows mixer.
You can check the PSK sending tone if you put your headphones in the soundcard output.

73 Ben

M0KCM
Beiträge: 4
Registriert: 21. Juli 2013, 20:18

Re: PSK Decodes in RX but no TX

Beitragvon M0KCM » 16. August 2013, 12:57

DL7UCX hat geschrieben:Hi Ian,

You have to set the right level using the windows mixer.
You can check the PSK sending tone if you put your headphones in the soundcard output.

73 Ben


Hi Ben

With headphones in my soundcard output, I hear the correct noises. But still no psk transmit :(
I have downloaded a freeware datamode logbook from a fellow "Mike Zero" and it works first time. This other software uses the MMVARI engine. I've now worked 30 dxcc on psk31 in just a few days. So, I know that the levels are good, and I know that the PTT link between my laptop and my radio are good. I much prefer the functionality of UCXLog, so I'm still looking for the solution.

Ian

Benutzeravatar
DL7UCX
Beiträge: 5016
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: PSK Decodes in RX but no TX

Beitragvon DL7UCX » 16. August 2013, 18:54

Hello Ian,

If I understand you correctly, you report that
- the radio is switched to "Send" by PTT
- you can hear the audio noise at the sound card output.

So all needed outputs of UcxLog are ok :!: :?:

Which audio input of your TRX do you use ?
What is your TRX model ?
Which mode is set in your TRX ?
Did you change the mode to PSK only in UcxLog ?
Did you try to change in "Settings-Station- Other interfaces - Soundcard - RTTY-PSK - TX" between SSB and PKT ?

73 Ben

M0KCM
Beiträge: 4
Registriert: 21. Juli 2013, 20:18

Re: PSK Decodes in RX but no TX

Beitragvon M0KCM » 20. August 2013, 14:59

DL7UCX hat geschrieben:Hello Ian,

If I understand you correctly, you report that
- the radio is switched to "Send" by PTT
- you can hear the audio noise at the sound card output.

So all needed outputs of UcxLog are ok :!: :?:

Which audio input of your TRX do you use ?
What is your TRX model ?
Which mode is set in your TRX ?
Did you change the mode to PSK only in UcxLog ?
Did you try to change in "Settings-Station- Other interfaces - Soundcard - RTTY-PSK - TX" between SSB and PKT ?

73 Ben


Hi Ben
I am using a windows 7 netbook.
Com 5 (USB) goes to a G4ZLP minipro interface. This connects with a 13 pin din connector into the rear of my Kenwood TS570. There are also 2 x 3.5mm plugs connecting to the onboard sound card of my netbook.
Com 6 (USB) goes to the 9 pin din connector on the rear of the TS570 (CAT control).

Using UCXlog, RTTY in afsk mode (LSB on radio). 100% perfect. Everything works as it should. If I select PSK in UCXlog (USB on radio), RX decode is 100%, when I TX, audio tones appear in headphones, radio moves into TX, but no power on the radio meter or antenna tuner. Just like keying a microphone on SSB and not talking...

If I then close UCXlog and open the freeware log software I downloaded (no adverts !!), using the exact same set up as above, this software works in RTTY and in PSK modes. No config changes, no hardware changes. Both programs are using MMTTY engine. So the output sound card levels are correct.

>Did you try to change in "Settings-Station- Other interfaces - Soundcard - RTTY-PSK - TX" between SSB and PKT ?

Yes tried that too. :-(

73 Ian

Benutzeravatar
DL7UCX
Beiträge: 5016
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: PSK Decodes in RX but no TX

Beitragvon DL7UCX » 20. August 2013, 17:25

Hello Ian,

Both programs are using MMTTY engine.

Attention, UcxLog doesn't use the MMTTY for PSK.
So there are 2 different settings for soundcard output, one in MMTTY for RTTY/AFSK and another one in UcxLog for PSK.

Are there the same sound output IDs in MMTTY and in UcxLog?

Because UcxLog PSK works for many users, I assume that you have inappropriate setting for sound output channel and TX audio input.

I don't know the G4ZLP minipro interface and I don't know what is required that the audio output signal is passed through to the TRX.

73 Ben


Postscript:
audio tones appear in headphones
Where are the headphones connected ?

I double-checked the CAT control for Kenwood TRX:
UcxLog sends exactly the same CAT command for RTTY/AFSK and for PSK.

Your Minipro interface don't need any adjustment.

DF7AT
Beiträge: 12
Registriert: 4. Januar 2014, 23:51

Re: PSK Decodes in RX but no TX

Beitragvon DF7AT » 2. Februar 2014, 13:56

Hallo,

ich habe das gleiche Problem; PSK dekodiert in RX, aber kein TX.

Start Up Message zeigt:
TRX 1: COM port 3 opened. Key Port COM 4 opened.
Soundcard "Speakers (Realtek High Definiti " opened OUT.
Soundcard "Mikrofon (2- USB Audio CODEC ) " opened IN.
No wave files found.

Es scheint, dass das Problem liegt an "No wave files found". Weiß jemand Rat?

Ich verwende Rig Expert Plus, IC-756PRO3, Win-7 64 Bit.

73! de DF7OGO / Gregor

Benutzeravatar
DL7UCX
Beiträge: 5016
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: PSK Decodes in RX but no TX

Beitragvon DL7UCX » 2. Februar 2014, 14:51

Hallo Gregor,

das Problem liegt nicht an "No wave files found", die sind für SSB-Senden.

Da liegt das Problem:
Soundcard "Speakers (Realtek High Definiti " opened OUT.
Soundcard "Mikrofon (2- USB Audio CODEC ) " opened IN.
Der PSK-Output geht auf den Ausgang der PC-Soundkarte ("Realtek") und nicht auf den "USB-Audio Codec" des Rig Expert.

Das ist das bekannte Problem, daß die PSKCore-DLL nur den gleichen Windows-Soundkarten-ID für Input und Output erlaubt, ich kann es nicht ändern.

Das läßt sich vorerst nur lösen, indem die RigExpert-Soundkarte als "Windows-Standard" eingestellt wird und in den UcxLog-Settings die Soundkarte "-1 Soundmapper" gewählt wird.

73 Ben

DF7AT
Beiträge: 12
Registriert: 4. Januar 2014, 23:51

Re: PSK Decodes in RX but no TX

Beitragvon DF7AT » 2. Februar 2014, 15:09

Hallo Ben,

vielen Dank für schnelle Antwort. Du hast recht,

Ich habe gerade festgestellt, dass TX funktioniert, wenn Soundcard ID PSK auf 1 eingestellt, d.h. OUT - "USB-Audio Codec" des Rig Expert. (RX funktioniert nicht, weil IN - Realtec" ist).
RX funktioniert, wenn Soundcard ID PSK auf 0 eingestellt, d.h. IN - "USB-Audio Codec" des Rig Expert. (TX funktioniert nicht weil OUT - Realtec" ist).

nochmal vielen Dank,

73! de DF7OGO


Zurück zu „Digitale Modes“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast