Verbindung UCXLOG - FLDIGI bricht ab

Moderator: DL7UCX

dl3ami
Beiträge: 2
Registriert: 10. November 2013, 18:15

Verbindung UCXLOG - FLDIGI bricht ab

Beitragvon dl3ami » 16. August 2014, 08:46

Hallo allerseits,
Zugegeben - ich nutze nur selten PSK o.ä. und habe dementsprechend wenig Erfahrungen damit.
Beim Einstellen der Betriebsart PSK in UCXLOG startet (meist) FLDIGI automatisch (Zeitverzögerung eingestellt). Es werden ein paar Zeilen von FLDIGI nach dem PSK-Fenster von UCXLOG übernommen, sodass man dort arbeiten könnte und die Vorteile von UCXLOG nutzen könnte.
Meist bricht aber die Verbindung FLDIGI - UCXLOG-PSK-Fenster nach ein paar Zeichen ab. (keine Fehlerausschrift). Besonders schnell kommt der Abbruch, wenn ich die QRG am TRX ändere, oder ein anderes PSK-Signal auswähle.
Technik hier: Win7 64 Bit, neuester Patchstand. Firewall, Virenscanner, Sandbox und alles was es so gibt ausgeschaltet. FLDIGI + UCX-LOG(Beta) neuester Stand. Rechte für beide Programmpakete auf "Jeder" gesetzt, einschließlich Testaufrufe "als Administrator" und diverse Kompatibilitätsmodes.
Nach einem solchem Verbindungsabbruch lässt sich UCXLOG meist nicht mehr beenden. Häufig auch nicht über den Taskmanager, sodass nur der Rechnerneustart bleibt.
Ich nehme auch an, dass die Meinungen und Wünsche der UCX-Log-Fans und die der FLDIGI-Fans aufeinanderprallen, sodass Ben Probleme hat, was er wie umsetzen kann und will. (s. Forenbeiträge)
Für meinen Teil ist mir das saubere Zusammenspiel mit UCXLOG wichtiger sodass ich wohl wieder zu PSKCORE wechsle und FLDIGI der anderen Lobby überlasse.
73 de Wolfram DL3AMi

Benutzeravatar
DL7UCX
Beiträge: 397
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: Verbindung UCXLOG - FLDIGI bricht ab

Beitragvon DL7UCX » 16. August 2014, 12:01

Hallo Wolfram,

besondere Rechte (Administrator, Firewall usw.) braucht UcxLog nicht, das hilft nichts.
Das Fldigi-Interface (XML-RPC) ist leider an Komplexität kaum zu überbieten, das geht tief durchs Windows incl. IP-Stack.
Störendes Ergebnis ist die Reaktionszeit von ca. 200ms pro Aufruf an Fldigi, dafür könnte Fldigi auch auf einem PC in VK laufen, das braucht ja auch fast jeder.

Wenn nur ein Rechner-Neustart hilft, klemmt es in einer Windows-Systemfunktion, da sehe ich keine Chance zur Lösung oder Abhilfe. Bei anderen ist so ein Fehler aber anscheinend noch nicht aufgetreten.

Wenn es nur um PSK geht, halte ich PSKCore sowieso für die bessere Lösung.

73 Ben

DD0VS
Beiträge: 3
Registriert: 26. Dezember 2011, 11:44

Re: Verbindung UCXLOG - FLDIGI bricht ab

Beitragvon DD0VS » 25. August 2014, 19:10

Hallo Ben,

ich habe ein relativ ähnliches Verhalten festgestellt.

In einem QSO kommt es dazu das mitten im Text die Weitergabe von UCX an FLDIGI nicht funktioniert und akustisch irgendein Zeichen ständig wiederholt wird.
Abhilfe schafft dann nur noch Escape.

In dem Zusammenhang:
In FLDIGI kann man mehrere F-Tasten in einer gewünschten Reihenfolge hintereinander drücken (ohne das der Text schon komplett gesendet wurde) und damit die Inhalte mehrer F-Tasten hintereinander übertragen.
Das ist mir so mit UCX-Log noch nicht gelungen.

Eigentlich könnte ich ja FLDIGI direkt nehmen, aber ich verstehe die Kontestfunktion dort nicht, und die von UCX-Log kenne und verstehe ich.

MTTY funktioniert (nur das Windows die Sound-IDs immer neu auswürfelt und die Lösung mit der Standard-Soundkarte den PC-Lautsprecher dann auch dorthin bringt :-(

vy 73
Harald

Benutzeravatar
DL7UCX
Beiträge: 397
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: Verbindung UCXLOG - FLDIGI bricht ab

Beitragvon DL7UCX » 26. August 2014, 06:02

Hallo Harald,

In einem QSO kommt es dazu das mitten im Text die Weitergabe von UCX an FLDIGI nicht funktioniert und akustisch irgendein Zeichen ständig wiederholt wird.
Abhilfe schafft dann nur noch Escape.
bei Dir scheint es ein anderes Problem zu sein, da es sich mit Esc beenden läßt und nicht tief in Windows hängt.
Fldigi scheint hier zu klemmen, UcxLog wiederholt kein Zeichen und Esc reagiert normal.

In FLDIGI kann man mehrere F-Tasten in einer gewünschten Reihenfolge hintereinander drücken (ohne das der Text schon komplett gesendet wurde) und damit die Inhalte mehrer F-Tasten hintereinander übertragen.
Das ist mir so mit UCX-Log noch nicht gelungen.
Ist ganz einfach, Pop-Up-Menü (rechte Maustaste) über einem F-Text und dann "F...: Insert" auswählen.
Da man das Pop-Up-Menü schlecht erahnen kann, gibt es dort ein kleines blaues Fragezeichen (auch an anderen Stellen), probiere das mal anzuklicken.

MTTY funktioniert (nur das Windows die Sound-IDs immer neu auswürfelt und die Lösung mit der Standard-Soundkarte den PC-Lautsprecher dann auch dorthin bringt
Eigentlich werden die Sound-ID in Windows nicht verändert. MMTTY braucht nicht den Trick mit dem Standard, das ist nur bei PSKCore mit verschiedenen In-Out-IDs notwendig.

73 Ben

DD0VS
Beiträge: 3
Registriert: 26. Dezember 2011, 11:44

Re: Verbindung UCXLOG - FLDIGI bricht ab

Beitragvon DD0VS » 27. August 2014, 19:22

Hallo Ben,

das Hängen Bleiben scheint sich mit Zeilenwechsel mit Enter oder # zu verschlimmern, passiert aber auch ohne und tritt auch bei händischer Texteingabe auf. Dummerweise kann man dann das QSO / Durchgang nicht mehr richtig abschließen.

Insert/Overwrite funktioniert.

Habe eine externe DMX6FireUSB Sound-"Karte" mit getrennten In- und Out- Kanälen, da fallen die IDs nur selten zusammen.
Auch die JT65-HF Software teilt mir manchmal mit das die IDs sich geändert haben.
(ist aber im Moment sekundär)

vy 73
Harald
DD0VS

Benutzeravatar
DL7UCX
Beiträge: 397
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: Verbindung UCXLOG - FLDIGI bricht ab

Beitragvon DL7UCX » 27. August 2014, 19:32

Sri Harald,

da habe ich erstmal keine weitere Idee :?

73 Ben

dl3ami
Beiträge: 2
Registriert: 10. November 2013, 18:15

Re: Verbindung UCXLOG - FLDIGI bricht ab

Beitragvon dl3ami » 23. Oktober 2014, 17:26

Hallo Ben,
ich bin vom allgemeinen UCXLOG - FLDIGI wieder hierher gewechselt, weil es scheinbar doch ein spezifisches Problem ist.
Danke für die UCXLOG-Beta-Version mit verlängerten Time-Out. LEider hat es kein durchschlagendes Ergebnis gebracht. Es schien etwas länger bis zum Abbruch zu dauern, aber es tritt auf.
Ich habe inzwischen auch einiges mehr an Tests durch: Untersuchung Problem IPV6 <--> IPV4, localhosts in die c:\windows\system32\drivers\etc\hosts eingetragen u.ä.m. Ich habe auch die Verbindungen mit "netstat" mal etwas mehr untersucht. Die Verbindung UCXLOG <--> FLDIGI auf dem Port 7632 ist vorhanden. Nach dem Abbruch "lauscht" FLDIGI auf Port 7632, aber keine Verbindung mehr.. ICh suche noch ein Tool mit dem ich ein tcpdump auf win7 64Bit auf dem "Interface" LO analog Linux machen könnte um eventuell mal den Verbindungsabbruch mit zu tracen.
Ich bleibe dran - denn mit Deiner "Modem only" Verbindung ist es interessant...

73 de Wolfram

Benutzeravatar
DL7UCX
Beiträge: 397
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: Verbindung UCXLOG - FLDIGI bricht ab

Beitragvon DL7UCX » 27. Oktober 2014, 12:57

Hallo Wolfram,

es ist augenscheinlich kein Laufzeitproblem, sondern der XML-RPC mißlingt sporadisch völlig, was zum TimeOut führt.
Beim lokalen Aufruf von RPCs sollte so etwas nicht vorkommen, scheint bei Dir aber doch zu sein, der XML-RPC ist eben sehr komplex.
Jetzt bricht UcxLog dann völlig ab, da kann Fldigi "lauschen" solange es will ...

Ich baue mal eine Wiederholung bzw. begrenzte Ignorierung im Fehlerfall ein, bitte etwas QRX.

73 Ben

dl3kvr
Beiträge: 81
Registriert: 18. November 2009, 09:55

Re: Verbindung UCXLOG - FLDIGI bricht ab

Beitragvon dl3kvr » 28. Oktober 2014, 08:41

Hallo ihr Zwei,
ob mein Einwurf hilft, weiss ich nicht.
Habe FLDIGI solo betrieben, also ohne UCX und es verworfen, weil da ebenfalls,
aus unklaren Gründen, während des QSOs abgebrochen wurde.
73 Diet

dl3ami
Beiträge: 2
Registriert: 10. November 2013, 18:15

Re: Verbindung UCXLOG - FLDIGI bricht ab

Beitragvon dl3ami » 28. Oktober 2014, 15:53

Hallo Diet,
danke für den Heinweis - ich bin jetzt mal dabei FLDIGI allein zu testen.
Es läuft jetzt eine halbe Stunde vollkommen problemlos.

Wo bricht bei Dir FLDIGI ab - in welcher Situation, bei der Verbindung welcher Komponenten (oder grundsätzlich), wie macht sich das bemerkbar - Browserfenster oder QSO-Fenster - Wasserfall läuft noch??
Versuche bitte mal ein paar zusätzliche Infos zu geben, das ich Ben nicht umsonst quäle

73 de Wolfram

dl3kvr
Beiträge: 81
Registriert: 18. November 2009, 09:55

Re: Verbindung UCXLOG - FLDIGI bricht ab

Beitragvon dl3kvr » 29. Oktober 2014, 16:44

Hallo Wolfram,
während des QSOs ging nichts mehr.
Bei MixW (da passiert so etwas aber nicht) startet man eben schnell neu.
Bei FLDIGI muß man dann einen Haufen neu eingeben. Nachdem mir das
öfters passiert ist, habe ich FLDIGI storniert.
73 Diet

Benutzeravatar
DL7UCX
Beiträge: 397
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: Verbindung UCXLOG - FLDIGI bricht ab

Beitragvon DL7UCX » 29. Oktober 2014, 18:35

Hallo,

das Problem ist eindeutig der XML-RPC (Remote Procedure Call), der im wesentlichen aus einem HTML-POST-Request über Windows besteht.
Dieser wird in UcxLog abgeschickt und es kommt ewig (> 1min) kein Response, nicht mal der 2-Sekunden-Timeout.
Meiner Meinung nach blockiert da etwas im Windows-IP-Stack, mir fällt dazu keine Lösung ein.
Solange das nur auf einem PCs auftritt muß/kann man damit leben, sri.

73 Ben

Benutzeravatar
DL7UCX
Beiträge: 397
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: Verbindung UCXLOG - FLDIGI bricht ab

Beitragvon DL7UCX » 4. November 2014, 15:02

Hallo,

das Problem hat sich bei Wolfram anscheinend dadurch behoben, daß er Fldigi deinstalliert und alle alten Fldigi-Registry-Einträge entfernt hat.

73 Ben

dl3ami
Beiträge: 2
Registriert: 10. November 2013, 18:15

Re: Verbindung UCXLOG - FLDIGI bricht ab

Beitragvon dl3ami » 25. November 2014, 10:53

Hallo,
bin am WE vom Urlaub zurückgekommen - Ben hatte ich schon vorab informiert.
Nachdem sich durch verschiedene Testversionen von UCXLOG herausgestellt hatte, dass es wohl ein individuelles Problem ist, habe ich am letzten Tag vor dem Urlaub nicht nur FLDIGI (zum soundsovielsten mal) deinstalliert, sondern auch das Dateisystem + die Registrie bezüglich FLDIGI durchgearbeitet. Was wirklich die Ursache war, ist nicht nachvollziehbar.
Auf jeden Fall läuft das Zusammenspiel UCXLOG <-> FLDIGI jetzt problemlos.

Vielen Dank bei Ben, DL7UCX, für den Superservice, die Begleitung bei der Fehlersuche und seine wahnsinnig kurzen Raktionszeiten. So etwas sucht seines gleichen!!!!!

73 de Wolfram DL3AMi


Zurück zu „Digitale Modes“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast