UCXLog and FLdigi?

Moderator: DL7UCX

do7dsw
Beiträge: 8
Registriert: 21. Mai 2013, 17:17

Re: UCXLog and FLdigi?

Beitragvon do7dsw » 17. April 2016, 15:56

Hallo Gregor,

richtig, in dem Send fenster z. B. CW tastet der TRX auf Sendung.
Vermute das Problem zwischen FLdigi und UCXLog.

Viele Grüße
Dirk - DL7DSW

DL9MEU
Beiträge: 73
Registriert: 15. August 2011, 18:23

Re: UCXLog and FLdigi?

Beitragvon DL9MEU » 17. April 2016, 17:44

Noch ne Frage:
Steht bei Settings FLDIGI auf "modem only"?
Wenn UCX und FLDIGI miteinander gekoppelt sind, redet nur UCX mit dem TRX. FLDIGI kann hat dann keinen Zugriff auf die Steuerung des TRX.
(Glit für "Modem only" und wenn FLDIGI komplett läuft).
D.h. Du kannst nur aus UCX heraus senden, nicht aus FLDIGI.
FLDIGI wird nur als Modem benutzt, d.h. um aus "Buchstaben Töne zu machen" und umgekehrt.
Wenn Du also aus dem FLDIGI versuchst zu senden, erzeugt zwar FLDIGI NF aber der TRX bekommt davon nichts mit.
Es geht nur aus dem "UCX Send" Fenster heraus.
73 de Gregor

PS: Die RIG-Steuerung im FLDIGI steht auf XML-RPC?

do7dsw
Beiträge: 8
Registriert: 21. Mai 2013, 17:17

Re: UCXLog and FLdigi?

Beitragvon do7dsw » 17. April 2016, 18:02

Modem only nutze ich nicht (kein Hacken)
Im Rig Control bei FLdigi ist der Hacken bei XML-RPC gesetzt. FLdigi startet auch bei der Auswahl "PSK..." im UCXLog automatisch.

DL9MEU
Beiträge: 73
Registriert: 15. August 2011, 18:23

Re: UCXLog and FLdigi?

Beitragvon DL9MEU » 17. April 2016, 18:13

Dann bleibt noch die Frage:
Von wo aus versuchst Du zu senden (= gibst Du den Text ein) aus dem UCX-Fenster oder aus dem FLDIGI-Fenster?

Der Betrieb des vollen FLDIGI-Fensters ist eigentlich ein Relikt aus der Zeit der Entwicklung heraus.
Aber
Für Hell ist das der einzige Weg, zusammen mit UCX QRV zu werden.
Empfehlung : Immer "Modem only" zu wählen, außer bei der Betriebsart HELL.
73 de Gregor

do7dsw
Beiträge: 8
Registriert: 21. Mai 2013, 17:17

Re: UCXLog and FLdigi?

Beitragvon do7dsw » 17. April 2016, 18:36

Richtig, wollte über das FLdigi Fenster senden, wir haben da Makros, etc. verwenden.
Modem only werde ich mir mal ansehen.

Sehr interessant.

Danke dir für die Infos. Werde das die Woche mal ausprobieren.

Viele Grüße
Dirk - DL7DSW

DL9MEU
Beiträge: 73
Registriert: 15. August 2011, 18:23

Re: UCXLog and FLdigi?

Beitragvon DL9MEU » 17. April 2016, 18:53

Alles klar, damit ist der Fall wohl gelöst....
Du musst in UCX unter "Send Digital" die Makros definieren (leider nicht ganz so umfangreich wie bei FLDIGI),
die dann auf den F-Tasten liegen.
Im Received Digital Fenster liegen unten ja auch die F-Tasten und sind mit der Maus betätigbar.
Wenn Du mit der rechten Maustaste auf die F-Tasten gehst, kannst Du diese beschriften.

73 de Gregor

do7dsw
Beiträge: 8
Registriert: 21. Mai 2013, 17:17

Re: UCXLog and FLdigi?

Beitragvon do7dsw » 17. April 2016, 19:12

Hallo Gregor,

ja, leider nicht so wie ich es mir gewünscht hätte.
Ich werde noch mit einem OM etwas rumprobieren, also Wochenaufgabe :-)

Viele Grüße
Dirk - DL7DSW

Benutzeravatar
DL7UCX
Beiträge: 5016
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: UCXLog and FLdigi?

Beitragvon DL7UCX » 18. April 2016, 16:23

Hallo Gregor,

ich mußte Dein Problem von Anfang April ruhen lassen, da ich zu AS-201 unterwegs war.
Es hat sich niemand sonst dazu gemeldet, ich muß wohl versuchen, es nachzustellen.

73 Ben

Nachtrag:
Ich vermute, das Problem hattest Du früher nicht.
In UcxLog hat sich nichts geändert.
Was hat sich denn bei Dir geändert ?

Benutzeravatar
DL7UCX
Beiträge: 5016
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: UCXLog and FLdigi?

Beitragvon DL7UCX » 18. April 2016, 16:26

Hallo Dirk,

der TRX wird von UcxLog auf Senden geschaltet.
Dazu muß aus Ucxlog gesendet werden, Fldigi wird nur als Modem verwendet, egal ob es nur als Modem oder komplett angezeigt wird.

73 Ben

DL9MEU
Beiträge: 73
Registriert: 15. August 2011, 18:23

Re: UCXLog and FLdigi?

Beitragvon DL9MEU » 18. April 2016, 18:22

DL7UCX hat geschrieben:Hallo Gregor,

ich mußte Dein Problem von Anfang April ruhen lassen, da ich zu AS-201 unterwegs war.
Es hat sich niemand sonst dazu gemeldet, ich muß wohl versuchen, es nachzustellen.

73 Ben

Nachtrag:
Ich vermute, das Problem hattest Du früher nicht.
In UcxLog hat sich nichts geändert.
Was hat sich denn bei Dir geändert ?


Hallo Ben,
war selbst auch unterwegs und kein "Werkzeug" dabei.
Das Problem ist definitiv neu, kann aber nicht sagen seit wann...
Geändert hat sich, dass ich den PC von Win7 auf Win10 upgedatet habe.
Vermute aber eher nicht, dass das ursächlich ist.
Zusätzlich habe ich einen neuen Laptop und einen FDM Duo, der aber die selben Symptome hat.
Ich werde mal versuchen ein älteres fldigi zu bekommen, und schauen, ob das was ändert.
73 de Gregor

DL9MEU
Beiträge: 73
Registriert: 15. August 2011, 18:23

Re: UCXLog and FLdigi?

Beitragvon DL9MEU » 27. April 2016, 18:08

Hallo Ben
habe mal in Ruhe versucht den Effekt reproduzierbar herzuleiten und zu beschreiben.

Ausgangsbasis
WIN 10 UCX 7.61 Beta 10 + FLDIGI 3.23.09.06, Modem only, QSY 1500 Hz, PSK freq= TX carr NEIN, TS480 + FA Interface
UCX wird auf 21,070 MHz und in PSK geschlossen.
Eingangszustand:
1.) Start UCX mit FLDIGI in PSK 31
2.) QSY funktioniert ordnungsgemäß, wenn QSY (Taste) ausgelöst wird und QRG bereits auf 1500 Hz steht, erfolgt keine Reaktion.
3.) Umschalten auf andere Betriebsart zB Olivia. Dabei wird automatisch ein QSY ausgelöst, d.h mit dem Start auf Olivia erfolgt ein Sprung auf 1500 Hz. >Fehlfunktion
4.) Wenn bereits auf 1500 Hz und QSY Taste betätigt wird, dann wird um 1500 Hz QSY gemacht, auch mehrmals jeweils um 1500 Hz, > Fehlfunktion
4a) wenn auf eine andere Betriebsart (außer PSK) z.B. Domino gesprungen wird, läuft des System weiter, jedoch werden die QSY fehlerhaft um 1500 Hz ausgeführt. > Fehlfunktion
Das System bleibt aber auf Domino, auch wenn QSY betätigt wird
5.) Umschalten auf PSK i.O.
6.) Wenn dann QSY gemacht wird, springt UCX auf SSB! >Fehlfunktion
Unmittelbar vor dem Abschalten von FLDIGI wird wieder die Bandbreite von Olivia angezeigt.
7.) Wenn dann wieder auf PSK gewechselt wird, ist die QSY Funktion wieder i.O.
Auffallend ist jedoch dass nach dem Start von PSK/FLDIGI kurz die Bandbreite von Olivia angezeigt wird.

Die Reaktion ist mit FLDGI 3.21.81 (ca 2 Jahre alt) identisch.
Die Reaktion ist ebenfalls identisch mit meinem Laptop WIN 10 und einem direkt angeschlossenen FDM Duo TRX (SDR).

Ich hoffe, dass Du das nachstellen kannst.
TNX und 73 de Gregor

Benutzeravatar
DL7UCX
Beiträge: 5016
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: UCXLog and FLdigi?

Beitragvon DL7UCX » 12. Mai 2016, 06:32

Hallo Gregor,

ich kann den Effekt nachstellen, es dauert aber noch etwas, die Abläufe zu analysieren ...

73 Ben

Benutzeravatar
DL7UCX
Beiträge: 5016
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: UCXLog and FLdigi?

Beitragvon DL7UCX » 3. Juni 2016, 10:13

Hallo Gregor,

in 7.63 Beta 1 habe ich wieder versucht, diese QSY-Funktion besser hinzubekommen.
Durch die erhebliche zeitliche Verzögerung der Daten sowohl von Fldigi als auch vom TRX ist das relativ unübersichtlich.
Hätte ich das nur nie eingebaut :?

3.) Umschalten auf andere Betriebsart zB Olivia. Dabei wird automatisch ein QSY ausgelöst, d.h mit dem Start auf Olivia erfolgt ein Sprung auf 1500 Hz. >Fehlfunktion
Dieses QSY beim Mode-Wechsel wird nicht von UcxLog ausgelöst, sondern von Fldigi alleine gemacht. Es sollte eigentlich auch nicht stören.

Die Verdopplung des QSY sollte behoben sein.

73 Ben

DL9MEU
Beiträge: 73
Registriert: 15. August 2011, 18:23

Re: UCXLog and FLdigi?

Beitragvon DL9MEU » 3. Juni 2016, 14:00

Hallo Ben
Vielen Dank für die Änderungen, ich habe wieder getestet

Ausgangsbasis
WIN 10 UCX 7.63 Beta 1 + FLDIGI 3.23.09.06, Modem only, QSY 1500 Hz, PSK freq= TX carr NEIN, TS480 + FA Interface
UCX wird auf 21,070 MHz und in PSK geschlossen.
Eingangszustand:
1.) Start UCX mit FLDIGI in PSK 31
2.) QSY funktioniert ordnungsgemäß, wenn QSY (Taste) ausgelöst wird und QRG bereits auf 1500 Hz steht, erfolgt keine Reaktion.
3.) Umschalten auf andere Betriebsart zB Olivia. Dabei wird automatisch ein QSY ausgelöst, d.h mit dem Start auf Olivia erfolgt ein Sprung auf 1500 Hz.
Wenn FLDIGI stand alone ausgeführt wird, wird kein QSY-Sprung ausgeführt. Bin mir ziemlich sicher, dass früher der Sprung nicht ausgeführt wurde. Ist insbesondere beim Contest bei Mode-Wechsel ziemlich hinderlich.
4.) Wenn bereits auf 1500 Hz und QSY Taste betätigt wird, erfolgt keine Reaktion. Jetzt i.O.
4a) wenn auf eine andere Betriebsart (außer PSK) z.B. Domino gesprungen wird, läuft des System weiter, jedoch werden die QSY auf 1500 Hz ausgeführt. Siehe Kommentar zu Punkt 3. Das System bleibt aber auf Domino, auch wenn QSY betätigt wird
5.) Umschalten auf PSK i.O.
6.) Wenn dann QSY (in PSK!) gemacht wird, springt UCX auf SSB! > Nach wie vor Fehlfunktion
Unmittelbar vor dem Abschalten von FLDIGI wird wieder die Bandbreite von Olivia angezeigt.
7.) Wenn dann wieder auf PSK gewechselt wird, ist die QSY Funktion wieder i.O.
Auffallend ist jedoch dass nach dem Start von PSK/FLDIGI kurz die Bandbreite von Olivia angezeigt wird.

Fazit: Die Sprünge um 1500 Hz sind behoben.
Die Sprünge beim Mode-Wechsel auf 1500 Hz (die FLDIGI stand-alone nicht hat) sind nach wie vor vorhanden, ebenfalls der unter 6 beschriebene Wechsel auf SSB.


TNX und 73 de Gregor

Benutzeravatar
DL7UCX
Beiträge: 5016
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: UCXLog and FLdigi?

Beitragvon DL7UCX » 3. Juni 2016, 20:07

Hallo Gregor,

in 7.63 Beta 2 sind hoffentlich beide restlichen Probleme behoben.

73 Ben


Zurück zu „Digitale Modes“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast