CW Tastung

Moderator: DL7UCX

DJ7MH
Beiträge: 6
Registriert: 26. April 2013, 15:45

CW Tastung

Beitragvon DJ7MH » 17. Januar 2015, 15:37

Moin moin,

seit heute ist folgenden Phaenomen.
Ich Taste cw ueber eine usb-rs232 schnittstelle die einen Transistortor schaltet und dann Tastet,
funktioniert seit 1 Jahr sehr gut, seit heute ist das so, das das letzte Zeichen einfach verschluckt wird...

Anstatt DJ7MH kommt DJ7Ms raus... das letzte dittt geht quasi verloren... und dss passiert bei jederm Zeichen so.

Jemand eine Idee?
Zuletzt geändert von DJ7MH am 17. Januar 2015, 19:44, insgesamt 1-mal geändert.

Benutzeravatar
DL7UCX
Beiträge: 397
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: CW Tastung

Beitragvon DL7UCX » 17. Januar 2015, 16:55

Hallo Marion,

ich würde erstmal ein anderes COM-Port (USB-Adapter) versuchen.

73 Ben

dl8dww
Beiträge: 24
Registriert: 1. August 2007, 19:14

Re: CW Tastung

Beitragvon dl8dww » 17. Januar 2015, 17:19

und was passiert wenn der letzte Buchstabe z.B . M ist ?
73 Wolfgang

DJ7MH
Beiträge: 6
Registriert: 26. April 2013, 15:45

Re: CW Tastung

Beitragvon DJ7MH » 17. Januar 2015, 19:43

Hi,

bei 2 Mitbewerbern meines lieblings Contestlogbuches funktioniert das richtig.
Es war auf einmal so, mitten im HA DX Contest heute.
Also an dem USB Wandler kann es nicht liegen, war auch mein erster Gedanke.

Ich habe keine Einstellungen etc. geändert.

Benutzeravatar
DL7UCX
Beiträge: 397
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: CW Tastung

Beitragvon DL7UCX » 18. Januar 2015, 07:58

Hallo,

ich kann keine mögliche Ursache in UcxLog erkennen, da hat sich nichts geändert und es hätte dann auch sofort Fehlermeldungen gehagelt.
Ich wüßte nicht, wie man mit "Einstellungen" diesen Fehler erzeugen könnte.

Was ist bei sehr langsamen Tempo?
Was passiert bei einem Strich am Ende?
Was macht der Mithörton ?
Schaltest Du die PTT-Leitung? Wie?

Was bedeutet genau "an dem USB-Wandler kann es nicht liegen" ?
Es könnte auch Software beschädigt sein, d.h. Treiber und UcxLog durch "Update" neu laden.
Welche UcxLog-Version benutzt Du?

73 Ben

DJ7MH
Beiträge: 6
Registriert: 26. April 2013, 15:45

Re: CW Tastung

Beitragvon DJ7MH » 18. Januar 2015, 15:30

Moin moin,

nach dem update ist es weg.

Es war auch bei dahs so, der Mithörton war ebenfalls abgehackt.
Auch ein dutzend Neustarts des PC´s und des Prgrammes hat nix gebracht,
mit N1MM und Wintest trat der Fehler nicht auf.
Absolut keine Erklärung.

Zum Glück funktioniert jetzt alles wieder!! :D :D :D

VY 73 DE Mario, DJ7MH

Benutzeravatar
DL7UCX
Beiträge: 397
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: CW Tastung

Beitragvon DL7UCX » 18. Januar 2015, 16:01

Hallo Mario,

wenn es nach dem Update weg ist, läßt sich das für mich nur damit erklären, daß die UcxLog.exe-Datei bei Dir beschädigt war.

73 Ben

Benutzeravatar
DL6ER
Beiträge: 31
Registriert: 7. März 2011, 20:42
Wohnort: Erftstadt nr Cologne
Kontaktdaten:

Re: CW Tastung

Beitragvon DL6ER » 18. Januar 2015, 18:50

Hallo Ben,

das mit der defekten Datei scheint ja doch irgendwie regelmäßig vorzukommen. Wäre es möglich die Programmdatei beim Start von Ucxlog gegen einen in einer anderen Datei abgespeicherten Hashstring (z.B. MD5) zu testen?
Ich würde jetzt einfach mal vermuten, dass das Programm selbst wenn es geöffnet ist, lesbar bleibt und sich so selbst prüfen kann.

73 Dominik

Benutzeravatar
DL7UCX
Beiträge: 397
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: CW Tastung

Beitragvon DL7UCX » 18. Januar 2015, 18:59

Hallo Dominik,

das überlege ich schon länger, aber es kommt doch viel seltener vor, als es zu erwarten wär (ich kenne vielleicht 2 Fälle, wo es wirklich so aussah).
Das bedingt für mich, vor dem Hochladen immer noch eine Checksummen-Generierung extra anzustoßen.
Die Checksumme würde ich dann schon innerhalb der UcxLog.exe ablegen.

73 Ben

Benutzeravatar
DL6ER
Beiträge: 31
Registriert: 7. März 2011, 20:42
Wohnort: Erftstadt nr Cologne
Kontaktdaten:

Re: CW Tastung

Beitragvon DL6ER » 18. Januar 2015, 19:04

Hallo Ben,

okay, dann habe ich das wohl einfach falsch im Gefühl. Dachte das schon recht häufig gelesen zu haben.
Ändert eine Checksumme in der Datei dann nicht wieder die Datei selbst, oder kann man einfach "segmentweise" überprüfen? :shock:

73 Dominik

dl8dww
Beiträge: 24
Registriert: 1. August 2007, 19:14

Re: CW Tastung

Beitragvon dl8dww » 20. Januar 2015, 07:48

Hallo Ben,
verstümmelte Zeichen könnte es auch geben, wenn PTT-Delay bei UCXLog und Flex-Software unterschiedliche Zeiten eingestellt sind.
Festgestellt hat es ein OM aus dem OV. Nachdem beide Zeiten auf Null gesetzt wurden waren die Zeichen wieder ok.
73 Wolfgang

Benutzeravatar
DL7UCX
Beiträge: 397
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: CW Tastung

Beitragvon DL7UCX » 20. Januar 2015, 09:14

Hallo,

die Checksumme dann in 7.47 Beta 7.
Bei der Berechnung/Prüfung wird die Stelle in der UcxLog.exe-Datei übersprungen, auf der die Soll-Checksumme gespeichert ist.
Wenn ich die Berechnung vergessen sollte, wird "CRC" gelb, bei Fehler rot und es kommt eine extra Meldung.

Zu PTT:
UcxLog schaltet die PTT immer genau nach dem letzten Zeichen ab, das einstellbare Delay ist nur zum Beginn !
Wenn andere eine "automatische" PTT-Abschaltung je nach vergangener Pausenlänge machen, kann das natürlich zu früh erfolgen.

73 Ben

dl8dww
Beiträge: 24
Registriert: 1. August 2007, 19:14

Re: CW Tastung

Beitragvon dl8dww » 20. Januar 2015, 14:05

CRC "grün" in Beta 7 (WIN Xp )
zu PTT: dann wird es wohl so gewesen sein, daß das erste Zeichen am Anfang gekürzt wurde. aus s wird i ( delay Flex5000 war 25ms höher als bei ucxlog)

Wolfgang


Zurück zu „Interfaces“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast