Probleme mit microham micro keyer 2

Moderator: DL7UCX

dg8hj
Beiträge: 4
Registriert: 12. April 2009, 14:33

Probleme mit microham micro keyer 2

Beitragvon dg8hj » 27. November 2017, 08:22

Hallo zusammen, hat noch jemand Probleme mit UCXlog und dem microkeyer 2.

Irgendwann, ich weiß leider nicht ab welcher Version trat folgender Fehler auf. Beim starten von ucxlog, schaltet das Interface die PTT.
mittlerweile habe ich herausgefunden, wie ich das weg bekomme. Ich schalte die PTT Einstellung im winkeyer von DTS auf RTS und danach wieder zurück auf RTS.
Danach läuft wieder alles normal.
Gestern habe ich leider auf die neue Bea Version geupdated und der winkeyer wolle nicht mehr richtig funktionieren.
Er sendet immer nur das erste Zeichen und mehr nicht. Das gilt sowohl für Makros, wie auch manuell eingegebne Texte bei den Funktionstasten.

Gibt es da Lösungsvorschläge??

Windows 7 ist das Betriebssystem, Transceiver ist ein TS-590.
vy 73 de Jan
DG8HJ

Benutzeravatar
DL7UCX
Beiträge: 366
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: Probleme mit microham micro keyer 2

Beitragvon DL7UCX » 27. November 2017, 08:37

Hallo Jan,

an dem WinKey -Interface hat sich ewig nichts geändert.
Da der WinKey von vielen verwendet wird, müßte ein Fehler in UcxLog auch schnell auffallen.

Ich habe meinen WinKey hervorgekramt, der läuft mit der Beta-Version wie immer problemlos, auch die PTT schaltet korrekt.

Wo und warum stellst Du denn DTR/RTS um?
Bei Winkey-Betrieb sind die Leitungen in den UcxLog-Settings gar nicht einstellbar (und für PTT bedeutungslos) ?

73
Ben

dg8hj
Beiträge: 4
Registriert: 12. April 2009, 14:33

Re: Probleme mit microham micro keyer 2

Beitragvon dg8hj » 27. November 2017, 08:54

Wo und warum stellst Du denn DTR/RTS um?


In der Microham Software für die PTT Steuerung, weil der TRX auf Sendung geht, sobald ich ucxlog starte.
Wenn ich DTR und RTS ändere und zurückändere funktioniert es.

Es ist halt merkwürdig, dass es auf einmal nicht mehr vernünftig gesendet hat. Ich habe es allerdings nicht mit verschiedenen Antennen getestet, es kann ja auch sein, dass HF irgendwo rein gestrahlt ist und daher das Interface abgeschaltet hat.

Benutzeravatar
DL7UCX
Beiträge: 366
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: Probleme mit microham micro keyer 2

Beitragvon DL7UCX » 27. November 2017, 09:59

Hallo Jan,

wenn Du mit WinKey arbeitest, kommen CW+PTT nicht von den TRX-COM-Port-Leitungen DTR+RTS sondern vom Key+PTT-Ausgang des WinKey :!:

73 Ben

Benutzeravatar
DL9GTB
Beiträge: 58
Registriert: 28. Mai 2011, 18:15
Wohnort: Nossendorf
Kontaktdaten:

Re: Probleme mit microham micro keyer 2

Beitragvon DL9GTB » 28. November 2017, 14:12

Ich verwende auch diese Kombination. Soweit läuft alles gut, auch mit der neuesten Beta. Allerdings kann ich das Problem beim Programmstart bestätigen, es wird immer die PTT geschaltet. Aber das war schon immer so und ich habe mich inzwischen daran gewöhnt.

Was mich wirklich stört ist die Umschaltung zwischen den jeweiligen Modes. Das kann schon mal bis zu 10 Sekunden dauern. Um z.B. von CW nach RTTY zu kommen muss ich erst auf SSB umschalten, wenn das nach einiger Zeit erfolgt ist weiter nach RTTY. Wenn ich direkt die Modes umschalte erscheint das MMTTY- Fenster nicht. Andersrum ist es auch so mit Fldigi. Das ist jedesmal sehr nervig, manchmal geht es schneller, manchmal langsamer. Was die Ursache ist weiß ich nicht, vermutlich vertagen sich UcxLog und die U-Router Software von microHAM nicht.

73 de Torsten - DL9GTB

Benutzeravatar
DL7UCX
Beiträge: 366
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: Probleme mit microham micro keyer 2

Beitragvon DL7UCX » 28. November 2017, 15:10

Hallo Torsten,

wie schaltest Du Key und PTT ?
Über den WinKey oder über COM-Port-Leitungen ?

Das Problem der Mode-Umschaltung höre ich zum ersten Mal.
Es könnte daran liegen, daß das CAT-Kommando zum TRX zu langsam übertragen wird.

73 Ben

Benutzeravatar
DL9GTB
Beiträge: 58
Registriert: 28. Mai 2011, 18:15
Wohnort: Nossendorf
Kontaktdaten:

Re: Probleme mit microham micro keyer 2

Beitragvon DL9GTB » 29. November 2017, 17:03

Hallo Ben,

ich schau mir die Einstellungen am Wochenende an wenn ich zu Hause bin, ich habe das jetzt so nicht im Kopf. Das Problem hatte ich von Anfang an bei der Kombination microHAM und UcxLog. Sonst mache ich mal ein kurzes Video, dann kannst du sehen wie es bei mir läuft. Ertl. liegt das auch daran das meine CAT-Ports vorher über einen seriellen Port Splitter laufen, den werde ich mal deaktivieren und dann noch einmal testen. Aber das hatte ich, so weit ich mich erinnere, bereits gemacht. Ich werde es aber noch einmal probieren.

73 de Torsten - DL9GTB

Benutzeravatar
DL7UCX
Beiträge: 366
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: Probleme mit microham micro keyer 2

Beitragvon DL7UCX » 29. November 2017, 17:27

Hallo Torsten,

in UcxLog sehe ich keine Möglichkeit für eine solche Verzögerung.
Wenn Du "Help - Trace System Events - TRX control" aktivierst, den Mode umschaltest und mir dann die Datei SYSLOG.TXT sendest, könnte man sehen, wobei es die Verzögerung gibt.

73 Ben

dg8hj
Beiträge: 4
Registriert: 12. April 2009, 14:33

Re: Probleme mit microham micro keyer 2

Beitragvon dg8hj » 4. Dezember 2017, 13:48

Hallo Ben, dass winkey auch die PTT für SSB und digimodes ersetzt war mir nicht bewusst.
Ich habe PTT ausgestellt und gestern bei dem kurzen BB Contest testen können. Läuft nun alles ufb.
Danke für die Hilfe

Benutzeravatar
DL7UCX
Beiträge: 366
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: Probleme mit microham micro keyer 2

Beitragvon DL7UCX » 4. Dezember 2017, 14:05

Hallo Jan,

da es nur eine PTT-Leitung gibt, muß UcxLog diese bei allen Modes schalten.
Bei Verwendung des WinKey kommt die PTT (für alle Modes) aus dem WinKey.
Eine interne Steuerung von Key/PTT des TRX über DTR/RTS darf dann nicht erfolgen, da dann zusätzlich und falsch vom CAT-Port geschaltet wird (abschalten in den TRX-Einstellungen).

73 Ben

Benutzeravatar
DL9GTB
Beiträge: 58
Registriert: 28. Mai 2011, 18:15
Wohnort: Nossendorf
Kontaktdaten:

Re: Probleme mit microham micro keyer 2

Beitragvon DL9GTB » 5. Dezember 2017, 07:51

Wie schalte ich denn die PTT aus? Jan, wie hast du das gemacht? Direkt in der Transceivereinstellung oder Softwareseitig?

73 de Torsten - DL9GTB

dg8hj
Beiträge: 4
Registriert: 12. April 2009, 14:33

Re: Probleme mit microham micro keyer 2

Beitragvon dg8hj » 6. Dezember 2017, 15:12

Ich habe einfach im Routerprogramm vom WK 2 die PTT auf none gesetzt.
hat bei mir dann geklappt.

Benutzeravatar
DL7UCX
Beiträge: 366
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: Probleme mit microham micro keyer 2

Beitragvon DL7UCX » 6. Dezember 2017, 18:01

Hallo,

warum müßt Ihr denn die PTT vom WinKey überhaupt ausschalten ?
UcxLog steuert die PTT doch nur an, wenn es weiß, daß gesendet werden soll.

Das Einschalten der PTT über falsch konfigurierte DTR/RTS-Signale sollte bei Torsten behoben sein.

73 Ben

DL5DBY
Beiträge: 12
Registriert: 2. März 2016, 15:35
Wohnort: Lindlar, nr Cologne

Re: Probleme mit microham micro keyer 2

Beitragvon DL5DBY » 8. Dezember 2017, 22:24

Hallo,
ich benutze seit ein paar Tagen einen Microkeyer II und habe jetzt ein Problem CW-Betrieb über WinKey zu machen. In der Router Konfiguration von dem MK2 habe ich die CAT Steuerung zum TRX ufb am laufen. CW-Betrieb mit aktivierten Key(CW) über CAT läuft auch. Konfiguriert im Reiter Transceiver. Ich möchte aber den CW-Betrieb über WinKey steuern. Dem Winkey habe ich im Router von MK2 eine virtuelle COM-Schnittstelle zugewiesen, die ich in UCX im Key/PTT control Fenster angegeben habe.
Dort habe ich WinKey Port 1 ausgewählt und darunter die COM Schnittstelle eingegeben. Danach wird in der MK2 Router Oberfläche unter Reiter Ports die WinKey-Verbindung zu UCX mit open 1200 8N2 angezeigt.
Drücke ich aber eine Funktionstaste z.B. F1 in UCX würde ich erwarten, dass mein TRX cq ruft. Aber da passiert nichts.
Kann mir jemand ein Tipp geben ?

Gruß Tom
vy 73 de Tom, DL5DBY

Benutzeravatar
DL7UCX
Beiträge: 366
Registriert: 8. August 2002, 17:23
Wohnort: Dabendorf
Kontaktdaten:

Re: Probleme mit microham micro keyer 2

Beitragvon DL7UCX » 9. Dezember 2017, 07:49

Hallo Tom,

ist der Schalter "VOX" im Send-Fenster angekreuzt ?
Läuft der Text aus dem Sende-Feld nach links heraus ?
Hast Du bei "Settings-Station-Other interfaces - WinKey " etwas verstellt?

73 Ben


Zurück zu „Interfaces“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast